Jump to content

[Solved] Problems Running Minecraft from Eclipse IDE


Recommended Posts

Hey I'm relatively new to Minecraft Modding using forge, I'm somewhat rehearsed with the Sponge API and I am a experienced Bukkit/Spigot Plugineer.

But up until now I've never actaully tried to run Minecraft from within the Eclipse IDE.

I tried following a few Tutorials from YouTube on how to do this but none work.


Strange part is though, when i use

./gradlew runClient

Everything runs fine aside from a weird spash.properties error or something.

But when I run in Eclipse using:


for my main class and

--userProperties, {}, --assetsDir, /home/darkwolf/.gradle/caches/minecraft/assets, --assetIndex, 1.8, --accessToken, {REDACTED}, --version, 1.8, --tweakClass, net.minecraftforge.fml.common.launcher.FMLTweaker, --tweakClass, net.minecraftforge.gradle.tweakers.CoremodTweaker

for the arguments I get the following error in my Eclipse 'Console'

[04:37:53] [main/INFO] [LaunchWrapper]: Loading tweak class name net.minecraft.launchwrapper.VanillaTweaker
[04:37:53] [main/INFO] [LaunchWrapper]: Using primary tweak class name net.minecraft.launchwrapper.VanillaTweaker
[04:37:53] [main/INFO] [LaunchWrapper]: Calling tweak class net.minecraft.launchwrapper.VanillaTweaker
[04:37:53] [main/ERROR] [LaunchWrapper]: Unable to launch
java.lang.NoSuchMethodException: net.minecraft.client.Minecraft.main([Ljava.lang.String;)
at java.lang.Class.getMethod(Class.java:1786) ~[?:1.8.0_51]
at net.minecraft.launchwrapper.Launch.launch(Launch.java:132) [launchwrapper-1.12.jar:?]
at net.minecraft.launchwrapper.Launch.main(Launch.java:28) [launchwrapper-1.12.jar:?]


So any help to understand how to resolve this would be greatly appreciated, In the meantime I guess I will just have to stick to using runClient from the command line


SideNote: I'm running on Ubuntu 14.04 if it matters

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.