Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

IntelliJ IDEA - Working import of Forge classes


rinart73
 Share

Recommended Posts

I imported a project in the IntelliJ IDEA, using a tutorial.

But lines such as

import net.minecraft.init.Blocks;

import net.minecraftforge.fml.common.Mod;

import net.minecraftforge.fml.common.Mod.EventHandler;

import net.minecraftforge.fml.common.event.FMLInitializationEvent;

have red color.

 

So, what I need to do to fix this?

Link to comment
Share on other sites

  • 2 weeks later...

Looks like you've not got the ForegBin src location setup correctly.

 

1) make sure you get the latest MDK and run two commands via terminal - first being "SetupDevWorkspace" as this will ensure all the gradle caches etc are aligned with that version and what not.

2) make sure you then run "gradle idea" as this should generate the IDEA files needed for you automatically.

3) Now, should that still fail, it could be a minor mapping issue in which case you go into Module Settings -> Dependencies. Add a dependency and locate your gradle cache directory (mine is C:\users\myname\.gradle\caches\minecraft\net\minecraftforge\forge\

4) There should be two directories with noting here, the first being "start" and second being "start". Add the Start directory by choosing just start and hit ok.

5) Then add another via the + in that same dialog, and this time navigate until you find forgeBin-1.8.x-XX.XX.X.XXXX.jar and choose it.

6) This should set you straight.

 

Failing this you've probably gone in a different direction that the IntilliJ IDEA herd in which case you probably should go back to the start and start with re-downloading the MDK into a clean directory, then run the above steps.

 

HTH.

Link to comment
Share on other sites

I got the same issue too, I followed the tutorial exactly as it said, and it I'm getting errors saying that the MCP mapping is meant for 1.8.8, not 1.8.9 and it also just immediately ends instead of running like it was with 1.8

Main Developer and Owner of Zero Quest

Visit the Wiki for more information

If I helped anyone, please give me a applaud and a thank you!

Link to comment
Share on other sites

I got the same issue too, I followed the tutorial exactly as it said, and it I'm getting errors saying that the MCP mapping is meant for 1.8.8, not 1.8.9 and it also just immediately ends instead of running like it was with 1.8

That's because each MCP mapping is for a specific version of Minecraft - you can't mix and match. The latest MCP mapping (i.e. current date) will probably always be for the latest Forge/Minecraft version, e.g. 1.8.9. If you are wanting to use an older Forge/Minecraft version, just keep turning back the date in your build.gradle's mappings setting until you get one that works.

mappings = "snapshot_20150617" // 1.8 mapping, specified by date rather than a specific MCP release
mappings = "stable_20" // specifically released stable 1.8.9 mapping, but you could change to 'snapshot_date' for more recent ones if you want

Link to comment
Share on other sites

Also.. I'm trying to switch to the latest version by changing the version in build.gradle in IntelliJ, I run the commands and everything but when I run the game, it still says the previous version of forge

Main Developer and Owner of Zero Quest

Visit the Wiki for more information

If I helped anyone, please give me a applaud and a thank you!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.