Jump to content

[1.8]Adding subtext to vanilla itemstacks


Mistram

Recommended Posts

Is there a way to add a subtext for vanilla itemstacks, depending on some data written in the nbt stack?

So lets say you could infuse a blaze rod with some stuff (written in the nbt) and then you would have the tooltip "This item has 4 infusions left"?

 

Link to comment
Share on other sites

Subscribe to

ItemTooltipEvent

and add lines to the list.

 

If NEI is running, this event won't be fired; so you need to implement

IContainerTooltipHandler

and register it using

GuiContainerManager.addTooltipHandler

.

 

I don't think JEI messes with this event, so you don't need to work around it like you do with NEI.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

I added the dev version of CodeChickenCore and NotEnoughItems and its throwing a ClassNotFoundException at me.. Any ideas..?

 

 

Exception in thread "main" [15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: java.lang.reflect.InvocationTargetException

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at java.lang.reflect.Method.invoke(Unknown Source)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.minecraftforge.gradle.GradleStartCommon.launch(GradleStartCommon.java:97)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at GradleStart.main(GradleStart.java:26)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: Caused by: java.lang.NoClassDefFoundError: codechicken/lib/asm/CC_ClassWriter

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at codechicken.core.asm.MCPDeobfuscationTransformer$LoadPlugin.injectData(MCPDeobfuscationTransformer.java:52)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.minecraftforge.fml.relauncher.CoreModManager$FMLPluginWrapper.injectIntoClassLoader(CoreModManager.java:143)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.minecraft.launchwrapper.Launch.launch(Launch.java:115)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.minecraft.launchwrapper.Launch.main(Launch.java:28)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: ... 6 more

[15:07:49] [main/INFO] [sTDERR]: [java.lang.Throwable:printStackTrace:-1]: Caused by: java.lang.ClassNotFoundException: codechicken.lib.asm.CC_ClassWriter

[15:07:49] [main/INFO] [sTDERR]: [java.lang.Throwable:printStackTrace:-1]: at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:191)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.Throwable:printStackTrace:-1]: at java.lang.ClassLoader.loadClass(Unknown Source)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.Throwable:printStackTrace:-1]: at java.lang.ClassLoader.loadClass(Unknown Source)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.Throwable:printStackTrace:-1]: ... 10 more

[15:07:49] [main/INFO] [sTDERR]: [java.lang.Throwable:printStackTrace:-1]: Caused by: java.lang.NullPointerException

[15:07:49] [main/INFO] [sTDERR]: [java.lang.Throwable:printStackTrace:-1]: at net.minecraft.launchwrapper.LaunchClassLoader.findClass(LaunchClassLoader.java:182)

[15:07:49] [main/INFO] [sTDERR]: [java.lang.Throwable:printStackTrace:-1]: ... 12 more

 

 

Link to comment
Share on other sites

It looks like CodeChickenLib is missing. CodeChickenCore usually downloads it automatically, but you may need to add it as a dependency manually in the development environment.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

No, it's only for 1.8 and earlier. Just Enough Items (JEI) is the 1.8.9 replacement for its item list and recipe viewing functionality.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

I guess I will be using JEI  then, since it supports 1.8.9.

Another problem I stumpled upon was adding the information to the itemstacks nbt.

I am triing to add 10 charges to each blaze rod that get depleted when doing stuff.

The problem is that the TagCompound is null the next tick, even if I set it in my code (This is running inside a ServerTickHandler)

 

ArrayList<EntityPlayer> player = Helper.getAllPlayer();
	for (EntityPlayer entityPlayer : player) {

		for (ItemStack itemStack : entityPlayer.openContainer.inventoryItemStacks) {
			if(itemStack==null) continue;
			if(itemStack.getItem() ==Items.blaze_rod) {
				NBTTagCompound compound = itemStack.getTagCompound();
				if(compound==null) {
					compound = new NBTTagCompound();
					itemStack.setTagCompound(compound);

				}
				if(!compound.hasKey("charges")) {
					System.out.println("setting compound");
					compound.setLong("charges", 10);
				}
			}
		}
	}

Link to comment
Share on other sites

Container#inventoryItemStacks

is just a cache that stores a copy of the container's contents. To modify the inventory itself you need to iterate through the container's slots (

Container#inventorySlots

), copy the stack in each slot (

Slot#getStack

,

ItemStack#copy

), modify the copy and then replace the slot's stack with the copy (

Slot#putStack

).

 

Don't directly modify the stack returned from

Slot#getStack

as the slot may be backed by an

IItemHandler

, which specifically forbids modifying the stack returned from

IItemHandler#getStackInSlot

.

 

I don't think that documentation is accurate, since the vanilla Skull item uses NBT to store the skull owner (for player skulls) and can be stacked.

 

If you're modifying the NBT of items not added by your mod, make sure you include your mod ID in the tag names so you don't overwrite other people's data.

 

Storing the infusion count could be a potential use-case for the new capability system.

Please don't PM me to ask for help. Asking your question in a public thread preserves it for people who are having the same problem in the future.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I had a similar issue to what you do above. Given this is an old post, you've probably sorted this now In my case, I had Java (JDK) 22 installed. After uninstalling that and installing 17.0.11 (having both installed gives the same error), then running the startserver.bat worked for me. I managed to get to the EULA section and then start my server correctly- I hope it helps anyone else who may have this issue!
    • Make a test with another Launcher like MultiMC, AT Launcher or Technic Launcher
    • I opened up Minecraft today for the first time in a month and whenever I try and play forge I get an error 1 message. I restarted my computer, tried reinstalling both Minecraft and Forge and have updated all of my drivers. Nothing seems to work so I'm stumped. I have absolutely no mods installed ATM so I have no idea what could be causing the problem. I hope yall are able to help.   DebugLog:   [19May2024 20:33:51.600] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--username, dmoy18, --version, 1.20.1-forge-47.2.0, --gameDir, C:\Users\dmoyf\AppData\Roaming\.minecraft, --assetsDir, C:\Users\dmoyf\AppData\Roaming\.minecraft\assets, --assetIndex, 5, --uuid, c083972cd92d4dd2894beb25b82ebe82, --accessToken, ????????, --clientId, MDljMzIwMjYtOTJiNS00YWUxLTk1M2EtN2ExMGExZWM0MDAw, --xuid, 2535417310772497, --userType, msa, --versionType, release, --quickPlayPath, C:\Users\dmoyf\AppData\Roaming\.minecraft\quickPlay\java\1716168829421.json, --launchTarget, forgeclient, --fml.forgeVersion, 47.2.0, --fml.mcVersion, 1.20.1, --fml.forgeGroup, net.minecraftforge, --fml.mcpVersion, 20230612.114412] [19May2024 20:33:51.604] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 10.0.9+10.0.9+main.dcd20f30 starting: java version 17.0.8 by Microsoft; OS Windows 11 arch amd64 version 10.0 [19May2024 20:33:51.634] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [fmlclientdev,forgeclient,minecraft,forgegametestserverdev,fmlserveruserdev,fmlclient,fmldatauserdev,forgeserverdev,forgeserveruserdev,forgeclientdev,forgeclientuserdev,forgeserver,forgedatadev,fmlserver,fmlclientuserdev,fmlserverdev,forgedatauserdev,testharness,forgegametestserveruserdev] [19May2024 20:33:51.653] [main/DEBUG] [cpw.mods.modlauncher.NameMappingServiceHandler/MODLAUNCHER]: Found naming services : [srgtomcp] [19May2024 20:33:51.668] [main/DEBUG] [cpw.mods.modlauncher.LaunchPluginHandler/MODLAUNCHER]: Found launch plugins: [mixin,eventbus,slf4jfixer,object_holder_definalize,runtime_enum_extender,capability_token_subclass,accesstransformer,runtimedistcleaner] [19May2024 20:33:51.681] [main/DEBUG] [cpw.mods.modlauncher.TransformationServicesHandler/MODLAUNCHER]: Discovering transformation services [19May2024 20:33:51.688] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path GAMEDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path MODSDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft\mods [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path CONFIGDIR is C:\Users\dmoyf\AppData\Roaming\.minecraft\config [19May2024 20:33:51.689] [main/DEBUG] [net.minecraftforge.fml.loading.FMLPaths/CORE]: Path FMLCONFIG is C:\Users\dmoyf\AppData\Roaming\.minecraft\config\fml.toml
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.