Jump to content

Download "installer" button not giving the correct file


fatfingers52

Recommended Posts

I'm trying to download the 1762 installer for Mac but it keeps downloading the "...win.exe" file.  The "win installer" button is correct and downloads the "...win.exe" file.

 

The last installer that I download that worked was version 1756.

 

I'm running Mac OS 10.11.3 using Safari 9.0.3.

 

Thank you,

Mike

 

2/24/2016 18:45 PST

 

Just tried it again and got the correct file.  Can't explain it.

 

Thank you.

Link to comment
Share on other sites

Give the exact page, and link you clicked to download. Screenshots help

Just checked the files page everything is fine.

 

 

Edit: Seems adfocus is having a caching issue, just use the direct downloads.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.