Jump to content

[1.8.9]Tile Entity different in gui


caroke

Recommended Posts

Hello, i made a custom block with his own tile entity.

 

So when i place it, i open a gui where i can write a string and add it to the tile entity.

But the Tile Entity is different from the one i create when i place the block, so it add the string but to a wrong tile entity.

Here is what i got after some print in eclipse:

 

[17:07:30] [Client thread/INFO] [sTDOUT]: [com.kidscode.kidscode.gui.GuiScreenBlockText:actionPerformed:82]: com.kidscode.kidscode.tileEntity.TileEntityTextChat@96fc177
[17:07:33] [server thread/INFO] [sTDOUT]: [com.kidscode.kidscode.block.BlockTextChat:onNeighborBlockChange:61]: com.kidscode.kidscode.tileEntity.TileEntityTextChat@7d681d0b

 

Looks like there is 2 entity for the same block pos, one for the server and the other one for the client.

 

I dont know how to resolve it :S

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.