Jump to content

[1.7.10] [SOLVED] onDeath event not triggering


Glistre

Recommended Posts

I found the mistake was checking for King instead of Queen because I had some other things with King so I need to have another event I suppose for two different entities

 

No event is triggered. Is something wrong with my code?( yes I check for King ...then Queen)

 

	@SubscribeEvent
public void onEntityTobieKingDeath(LivingDeathEvent event){
	if (!event.entityLiving.worldObj.isRemote ){
	if(!(event.entityLiving instanceof EntityTobieKing)){
		return;
	}
	if (event.entityLiving instanceof EntityTobieQueen){
		DamageSource source = event.source;
		EntityTobieQueen queen = (EntityTobieQueen) event.entityLiving;		
		if (source.getEntity() instanceof EntityPlayer) {
			EntityPlayer sourcePlayer = (EntityPlayer) source.getEntity();
			sourcePlayer.addStat(GlistreMod.mobKillAchievement_1, 1);	
			sourcePlayer.addChatMessage(
					new ChatComponentText(EnumChatFormatting.GOLD + "YOU KILLED THE EVIL TOBIE QUEEN ELIZABETH!!!!"));
			sourcePlayer.addPotionEffect(new PotionEffect(Potion.fireResistance.id, 2500, 0));
			sourcePlayer.addExperience(50000);}

 

 

Link to comment
Share on other sites

Is it not triggering as in method is not even called? In that case - did you register event class?

 

Else (it is called, just doesn't do stuff) at what point it doesn't?

1.7.10 is no longer supported by forge, you are on your own.

Link to comment
Share on other sites

Is it not triggering as in method is not even called? In that case - did you register event class?

 

Else (it is called, just doesn't do stuff) at what point it doesn't?

 

Methinks registered okay ...I have this in init of my main class and the event seems to work when I tried other methods just not

with the method #addstat or #addPotionEffect  or #addChat

 

Seems like it's just not picking up the player who kills the mod

GlistreEventHandler handler = new GlistreEventHandler();
FMLCommonHandler.instance().bus().register(handler);
MinecraftForge.EVENT_BUS.register(handler);	

 

Link to comment
Share on other sites

Your logic appears to be problematic:

if(!(event.entityLiving instanceof EntityTobieKing)){
return; // returning if entity is not an EntityTobieKING
}
if (event.entityLiving instanceof EntityTobieQueen){ // how will this ever be true???

Unless EntityTobieQueen extends EntityTobieKing, that second statement will never be true.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • What MC version? What's the IP? Are any mods needed to be able to join?
    • Thank you for your answer ! Unfortunatly i have the same problem when i use setPos() public static int movingfunction(CommandContext<CommandSourceStack> context){ CommandSourceStack source = context.getSource(); if (!(source.getEntity() instanceof ServerPlayer)) { return 0; } ServerPlayer player = (ServerPlayer ) source.getEntity(); double moveSpeed = 0.5; for (int i =0; i<10000;i++) { LOGGER.info("running for the {} time", i); double x = player.getX() + player.getViewVector(1.0f).x * moveSpeed; double y = player.getY(); double z = player.getZ() + player.getViewVector(1.0f).z * moveSpeed ; Vec3 movementVec = new Vec3(x, y, z); LOGGER.info("x ={} y ={} z ={}", x, y, z); player.setPos( movementVec); } return 1; } With the logs i can see that x and z are increasing but once again my player is not moving. is there a function to use to sync the server and the client ? I also tried to use LocalPlayer instead of ServerPlayer but my code would stop when i got the object. Also i will change a bit the main topic but is there a way to similate key press ? i found KeyBinding.setKeyBindState on others post but it look like there is no more KeyBinding in 1.20   I found this code : KeyMapping.click(Minecraft.getInstance().options.keyUp.getKey()); But it doesn't seems to work   And i found this one : Minecraft.getInstance().options.keyUp.setDown(true); wich works but doesn't exactly do what i want , it doesn't release the key so for exemple i can't make him run. Minecraft.getInstance().options.keyUp.setDown(true); Minecraft.getInstance().options.keyUp.setDown(false); Minecraft.getInstance().options.keyUp.setDown(true); doesn't make him run
    • Add crash-reports with sites like https://paste.ee/ Maybe an issue with blur, essentials or cumulus_menus
    • Add the crash-report or latest.log (logs-folder) with sites like https://paste.ee/ and paste the link to it here  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.