Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

null pointer exception with @Mod


Recommended Posts

When I try and make a mod, the main file causes Minecraft to crash upon startup. It even crashes when this is my entire main file:

package gas.common;

import cpw.mods.fml.common.Mod;
import cpw.mods.fml.common.network.NetworkMod;

@Mod(modid = "GasMod", name = "Gas", version = "1.0")
@NetworkMod(clientSideRequired = true, serverSideRequired = false)

public class GasMain {



Note: I've tried adding init, preinit, etc. methods to the class and it gives me the same result.

This is the Crash log http://pastebin.com/W6VSTwHs

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.