Jump to content

gradlew build hangs at 82% retromapReplacedMain


Recommended Posts

Hello, I am currently trying to build a new version of a mod, but every time I try (using 'gradlew clean build') it hangs indefinitely at 82% ':retromapReplacedMain'. I am trying to build the project that can be found here.


The debug logs can be found here.


I have searched online for about 3 days for a solution and found nothing that worked, so I figured asking was now justified. Sorry if the answer is staring me in the face.

Link to comment
Share on other sites

Why are you calling

gradlew clean

? It clears the cache, which you probably don't want. Just calling

gradlew build

will suffice.

Don't PM me with questions. They will be ignored! Make a thread on the appropriate board for support.


1.12 -> 1.13 primer by williewillus.


1.7.10 and older versions of Minecraft are no longer supported due to it's age! Update to the latest version for support.



Link to comment
Share on other sites

The issue persists even when I don't run clean. I do it just in case there is any cache issues that might be causing/adding to the issue, or in case the issue leaves behind any problems. I don't know quite how resistant gradle is to having jobs interrupted mid-action.

Link to comment
Share on other sites

  • 3 weeks later...

In the (apparent) absence of anyone who knows how to solve this problem, is anyone able to point me towards some tips in order to work out what is causing the problem? Are there any additional debugging steps that I can take to, for example, narrow it down to a particular class causing the issue? I have tried looking at the debug logs posted above, but am unable to discern any information regarding the issue.

Link to comment
Share on other sites

  • 1 month later...

Sort of...

I found that after aborting the operation there was a .jar in the output directory that looked good. I tested it thoroughly and it worked, but I am unsure if there are any hidden problems that may surface later. Use at your own risk?

Its not ideal, but it works (for now). I hope they find the cause of this issue and I am happy to help them in any way I can.

I hope that helps. :-\

Link to comment
Share on other sites

That did help, but I've since found a more reliable solution (thanks Greymirk!)


in your build.gradle, in the minecraft {} section, add "

makeObfSourceJar = false



So, mine looks like this:


minecraft {
    version = "1.11.2-"
    runDir = "run"
mappings = "snapshot_20170120"
makeObfSourceJar = false


Now, if you needed the obfuscated source JAR this isn't going to help you. But if you DIDN'T (and I don't even know what that's for, so I don't) this will make the problem go away.

  • Thanks 1
Link to comment
Share on other sites

I had same issue before and found solution from this post: http://www.minecraftforge.net/forum/index.php?topic=42150.msg223961#msg223961


If there are some class file contain NO IMPORT and 3+ BLANK LINES at the end of file, then the building will fail or just hang at 82% retromapReplacedMain.


You can find what class file the building is hanging at by log file:

(mod working folder)/build/taskLogs/retromapReplacedMain.log


In my experience, it happens in forge 1.10.2#?~2221, but forge 1.7.10 is working fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.