Jump to content

[SOLVED] Crash on Trying to Render Entity


Jimmeh

Recommended Posts

Hey there!

 

So I've made a custom Entity, EntityGuard. There are no errors on loading, however whenever it tries to render the entity (whether from me placing it or a natural spawn), the client crashes.

 

For the sake of not making this one post the length of the screen, I'll provide hastebin links to all my classes.

 

Here's my EntityGuard class:

http://hastebin.com/upanerumed.java

 

Here's my ModelGuard class:

http://hastebin.com/ehelilukiy.java

 

Here's my RenderGuard class:

http://hastebin.com/purehowidu.scala

 

And here's where I'm registering it client side:

http://hastebin.com/dicicezoyi.java

 

If it helps, here's the crash:

http://hastebin.com/ogebohuwub.pas

 

And here's the console log prior to the crash report being printed:

http://hastebin.com/ginuvafoka.md

 

Any help is greatly appreciated! :D

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.