Jump to content

MC1.10+ setHarvestLevel seems not to work


Recommended Posts

I am adding support for biomes o plenty in my mod currently and i discovered that this isn't doing anything. At least it looks like it.

Because i am making slabs and stairs for the biomesoplenty stones i need them to behave exactly the same.

There is a harvestlevel set for limestone, siltstone and shale but they do not work. So i tried this on my blocks too but it doesn't work either!


This is what i have set

public BlockBOPStonesBlockSlab1(String unlocalname, String registryname) {
	useNeighborBrightness = true;
	IBlockState state = this.blockState.getBaseState();
	//state.withProperty(VARIANT, false);
	state.withProperty(TYPE, EnumType.LIMESTONE);
		state.withProperty(HALF, EnumBlockHalf.BOTTOM);
	this.setHarvestLevel("pickaxe", 1, this.blockState.getBaseState().withProperty(TYPE, EnumType.LIMESTONE));
        this.setHarvestLevel("pickaxe", 2, this.blockState.getBaseState().withProperty(TYPE, EnumType.SILTSTONE));
        this.setHarvestLevel("pickaxe", 3, this.blockState.getBaseState().withProperty(TYPE, EnumType.SHALE));
	// TODO Auto-generated constructor stub


And this is how it looks in biomesoplenty's class:

public BlockBOPStone()

        // set some defaults
        this.setHarvestLevel("pickaxe", 1, this.getDefaultState().withProperty(VARIANT, StoneType.LIMESTONE));
        this.setHarvestLevel("pickaxe", 2, this.getDefaultState().withProperty(VARIANT, StoneType.SILTSTONE));
        this.setHarvestLevel("pickaxe", 3, this.getDefaultState().withProperty(VARIANT, StoneType.SHALE));
        this.setDefaultState( this.blockState.getBaseState().withProperty(VARIANT, StoneType.LIMESTONE).withProperty(POLISHED, Boolean.valueOf(false)) );

In my opinion the bop version is wrong. There he calls getDefaultState before it has been set. Even if you switch it, i think it's still wrong and he should use getBaseState. Because a default state has already a property set and then you give it another property. I can be wrong too afcourse...

Anyone setharvestlevel doesn't work for me.


Link to comment
Share on other sites

You didn't show us the parent constructor or either class's version of getDefaultState(), so we can't judge whether that call is wrong. I suspect that it is ok.


When I can't see how some segment of code could possibly work (but when I run it, it seems to), I run it in the debugger to see with my own eyes how the pieces come together.


If you find a bonafide error in BoP, then contact the mod developer directly. If it's popular, you might find it in Forge's Mods Forum.

The debugger is a powerful and necessary tool in any IDE, so learn how to use it. You'll be able to tell us more and get better help here if you investigate your runtime problems in the debugger before posting.

Link to comment
Share on other sites

I already contacted them, because it isn't working. Shale should be only mineable with diamond pickaxe but i can mine it with wooden pickaxe. So i can state the code in the bop class doesn't work.


It also doesn't work for me and i do not know why.

Yet if i remove the third argument( the state argument) , it is working fine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.