Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

winnetrie

Members
  • Posts

    408
  • Joined

  • Last visited

Everything posted by winnetrie

  1. Thank you Curle! I think it is working now, and i have all the libraries now. It's totally different then i was used to Edit i can also see all the commands in the gradle tasks tab, nice!
  2. I still need help with this. I have no idea how to proceed and googling doesn't provide any help either. I don't find any proper documentation or tutorial for this. I havent touched modding since 1.12.2, so many things changed it seems.
  3. Yes i did, but i have a feeling it doesn't look right and if i try to launch it it can't: The selection cannot be launched, and there are no recent launches
  4. Hi, I have troubles setting up my workspace in eclipse I followed the instructions at https://mcforge.readthedocs.io/en/1.14.x/gettingstarted/ but it doesn't work. Did anything changed? What i did: -Make a folder on my desktop -download the mdk.zip from forge -Put in in the created folder and unpack it -Start a command in that folder "gradlew genEclipseRuns" -Open Eclipse -At this point i'm unsure what to do now
  5. Thank you for answering and my apoligies for bothering you. On fabric they say : forge is old and laggy. Fabric is new and shiny. I disagree. I prefer forge and i think you do all great work.
  6. Hi, all. This post is not about criticizing or demand anything. Please do not be offended, i merely trying to understand things why and how. So i saw on Reddit the Fabric team bragging having released their Fabric modloader 2 minutes after mc 1.16 released. I wonder how can they do that so fast and forge not? Is Forge much more complicated? Do the Forge devs have no time/money/resources? Is fabric being sponsored? What's holding up the Forge team? Is there anything we can help? What's the difference between Fabric & Forge?
  7. I just wanted to make a new screenshot and discovered the folder where the block models are, is empty....?. I don't understand why it is empty. All files are gone. I'm pretty sure i didn't deleted it. So i made 1 new file for the that 1 block model and now it works properly. I Really don't know what to say. I have been trying to make this work for a whole week, modifying the files over and over again to test this and that. I really wonder what i modified all the time when the folder is empty.... It's working now, so thank you for your time. Btw it seems that creating a blockstate file with a forge marker doesn't work anymore. Or not that i know anyway. So now i have to create all files. 1 blockstate, 1 block model and 1 item model for each block i add to the game. Lot's of work, but i'll get there
  8. You asked me about the package, i gave you a screenshot and i asked you if something changed about it. Like is it different now then in 1.12.2. I gave you my latest log. There are only 2 lines relevant. There is nothing else in the log, just the usual stuff in every log. I used the registry, because i was told to do so. I had my own stuff before (a list), but i was told not to use that because it was redundant. What do you want to see about the models.blocks? It is too long to fit in a screenshot. They are just filenames like for example "somename.json" I made a fresh log for you: log
  9. Has something changed about that? Because you ask It only does not work for blocks. Any item i add to the game is rendered properly and works fine. Only the for the blocks it can't find model files
  10. Yes i know that, i needed it some long time before and never got rid of it. Anyway that doesn't solve my problem. All blocks are still purple/black squares and the game still doesn't find any (block and item) models for those blocks
  11. I'm still stuck on this. Any help would be nice.
  12. Alright. I have only 1 block enabled in my mod for the sake of testing. This is what i have so far: blockstate: { "variants": { "": { "model": "winnetriesexpansionmod:block/black_stained_clay" } } } block model: { "parent": "block/cube_all", "textures": { "all": "winnetriesexpansionmod:blocks/black_stained_clay" } } item model: { "parent": "winnetriesexpansionmod:block/black_stained_clay", "display": { "thirdperson": { "rotation": [-90,0,0], "translation": [0,1,-3], "scale": [0.55,0.55,0.55] }, "firstperson": { "rotation": [0,-135,25], "translation": [0,4,2], "scale": [1.7,1.7,1.7] } } } All 3 files are called black_stained_clay.json This is what appears in the log: [09aug2019 20:55:15.459] [Server-Worker-2/WARN] [net.minecraft.client.renderer.model.ModelBakery/]: Unable to load model: 'winnetriesexpansionmod:block/black_stained_clay' referenced from: winnetriesexpansionmod:black_stained_clay#: java.io.FileNotFoundException: winnetriesexpansionmod:models/block/black_stained_clay.json [09aug2019 20:55:15.931] [Server-Worker-2/WARN] [net.minecraft.client.renderer.model.ModelBakery/]: Unable to load model: 'winnetriesexpansionmod:black_stained_clay#inventory' referenced from: winnetriesexpansionmod:black_stained_clay#inventory: java.io.FileNotFoundException: winnetriesexpansionmod:models/item/black_stained_clay.json There are no other errors or relevant problems. This is how i register the block: @EventBusSubscriber(modid = References.MOD_ID, bus = EventBusSubscriber.Bus.MOD) public class ModRegistry { @SubscribeEvent public static void onItemRegister(RegistryEvent.Register<Item> event) { System.out.println("Registering all items"); //REGISTERING ALL ITEMBLOCKS for (Block block : ForgeRegistries.BLOCKS.getValues()) { if (block.getRegistryName().getNamespace().equals(References.MOD_ID)) { event.getRegistry().register(new BlockItem(block, new Item.Properties().group(Utilities.WINNETRIESEXPANSIONMOD)).setRegistryName(block.getRegistryName())); } } } @SubscribeEvent public static void onBlockRegister(RegistryEvent.Register<Block> event) { System.out.println("Registering all blocks"); //REGISTERING ALL BLOCKS event.getRegistry().registerAll( ModBlockReference.black_stained_clay = new Block(Block.Properties.create(Material.CLAY, MaterialColor.BLACK_TERRACOTTA).hardnessAndResistance(0.6F).sound(SoundType.GROUND)).setRegistryName(new ResourceLocation(References.PREFIX + "black_stained_clay")) ); } }
  13. No sorry, i didn't had time to do that + i do not fully understand how github works. I also do not have enough ready to upload it to git anyway
  14. For some reason i don't know, minecraft/forge cannot find the files for the models for my blocks. I get this message: Unable to load model: 'winnetriesexpansionmod:block/black_stained_clay' referenced from: winnetriesexpansionmod:black_stained_clay#: java.io.FileNotFoundException: winnetriesexpansionmod:models/block/black_stained_clay.json I checked like 100 times, but the file is there in that folder, yet it still keeps saying "filenotfoundexception" I don't know what to do
  15. Ah, i didn't know i could parse in a null. I never understood why there isn't just a simple method for it. Just 1 without parameters. Like other getters. However i can set those values manually and perhaps this is more common to do, but how unlikely it will be, in future updates it's always posseble those values changes. In this case if the blockhardness of bricks ever changes , my bricks their hardness will Always be the same. It is also less typing. I could maybe just make a constant for the value, so if it ever changes i just have to change the constant's value
  16. Oh so i set them all in the super? I really like this "properties" thing EDIT: How do i now "get" the hardness and resistance from an other block?
  17. I'm updating my mod to 1.14.4 (coming from 1.12.2) and a lot have changed. Some of my blocks are relying on some "properties" from other blocks. For example resistance, hardness, mapcolor. Are there any getters for those, or how would i retrieve those values? An example for that is i have , in addition to the vanilla bricks, added 16 more (colored) bricks. They all need to have the same properties except the mapcolor as the vanilla bricks. I can ofcourse add those properties at instantiation, but since they all are "the same" i want it to be inside the class. This way it saves me alot of work. I have done this for 1.12.2. Now it doesn't work like that. So i wonder if there are other ways now.
  18. Oh right. Like this i think: @EventBusSubscriber(modid = References.MOD_ID, bus = EventBusSubscriber.Bus.MOD) I have a class(References) where i put all my references in, for example : MOD_ID
  19. Ok So if i understand it right, i can still register my items and blocks the same way i did in 1.12.2? How i did that is creating a class (i called it ModRegistry) @EventBusSubscriber public class ModRegistry { @SubscribeEvent public static void onItemRegister(RegistryEvent.Register<Item> event) { System.out.println("Registering all items"); event.getRegistry().registerAll(somestuff here...); } @SubscribeEvent public static void onBlockRegister(RegistryEvent.Register<Block> event) { System.out.println("Registering all blocks"); event.getRegistry().registerAll(somestuff here...); } } Is that still correct?
  20. I Looked around at some other modders github pages to get a better understanding how things works. I see them all adding this to their main class: public static final CommonProxy PROXY = DistExecutor.runForDist(() -> ClientProxy::new, () -> CommonProxy::new); Then they call on PROXY in the events like FMLCommonSetupEvent They also have a ClientProxy that extends on a CommonProxy I'm a bit confused here, because i see no reason to extend the ClientProxy from CommonProxy.
  21. I have so many questions, i do not know where to start. Is there also some documentation for 1.14.x? Coming from 1.12.2 as i see there is a huge difference and i'm a bit confused how things work now. No events for preinit, init, and postinit. It seems that you don't need to register itemmodels anymore? Is that correct? It also looks like you no longer have to register an itemslab for slabs ? I have some troubles figuring out how to add fluids to the game now and how to setup a config. Config had completely changed i guess? Also what's the thing with this logger? What does it do and why we need to use it? I'm trying to understand all these new things. Don't understand me wrong (if you did), i'm not questioning if we should or not, i only want to know why.
  22. Does no 1 knows how to fix this? It is really ennoying!
  23. For a reason i haven't figured out yet, peoples signatures are not visible. Does anyone know why and how i can fix this? I tried other browsers, i'm not blocking any adds. Not even my own signature is visible to me!
  24. nope i'm not seeing that. I was wondering if i was too stupid to see it hehe
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.