Jump to content

build keeps spinning at "remapping source..."


Recommended Posts

debug dump at https://1drv.ms/t/s!AqTWbM9NKFyOrSmxDfI5TIOACLr_


I'm trying to build a fork of Greymerk's Roguelike Dungeons but it keeps stalling at



remapping source...


It has one core pegged out at max, and after several attempts I let it run overnight, but it's still sitting there and I have no signs of progress.


I've tried groveling over the debug dump but there's nothing obviously awry (not that I'm familiar with gradle's internals anyways). Where do I go from here for troubleshooting?


EDIT: I should note I've tried a clean and setupDecompWorkspace again (and again and again), and even a cleanCache. No particular change in behavior.

Link to comment
Share on other sites

For the next person with this problem:


I've found a solution (thanks Greymirk!)


in your build.gradle, in the minecraft {} section, add "

makeObfSourceJar = false



So, mine looks like this:


minecraft {
    version = "1.11.2-"
    runDir = "run"
   mappings = "snapshot_20170120"
   makeObfSourceJar = false


Now, if you needed the obfuscated source JAR this isn't going to help you. But if you DIDN'T (and I don't even know what that's for, so I don't) this will make the problem go away.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.