Jump to content

asyle.conf permission denied


Colecf

Recommended Posts

I'm trying to install minecraft forge, which I've done before, but for some reason when I run install.sh I get this error:

 

~/code/forge1.4.6-controller$ ./install.sh
================ Forge ModLoader Setup Start ===================
MCP Detected already, not downloading
Setting up MCP
Restoring commands.py backup
patching file commands.py
Commands patch applied successfully
Traceback (most recent call last):
  File "install.py", line 49, in <module>
    main(os.path.abspath('mcp'))
  File "install.py", line 18, in main
    setup_mcp(fml_dir, mcp_dir, True)
  File "/Users/Cole/code/forge1.4.6-controller/fml/fml.py", line 694, in setup_mcp
    shutil.rmtree(mcp_conf)
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 249, in rmtree
    onerror(os.remove, fullname, sys.exc_info())
  File "/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/shutil.py", line 247, in rmtree
    os.remove(fullname)
OSError: [Errno 13] Permission denied: '/Users/Cole/code/forge1.4.6-controller/mcp/conf/astyle.cfg'
~/code/forge1.4.6-controller$

 

MCP refuses to be run as root, so that's not an option. The file is there, and I haven't opened it or anything. The permissions on it are -rw-rw-r--  1 root  admin, like most everything else in the folder. What am I doing wrong?

 

This is on forge 6.5.0.489

Link to comment
Share on other sites

Something is not allowing your script to remove that file, whatever way you are running python doesnt have permission to remove it.

 

Possibly have the folder/file open elseware?

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Figured it out, somehow the owner for mcp/conf was root instead of me. I chown -R'ed that (-R was neccicary, there was another subfolder with the same problem) and got another error with RXTXcomm.jar, which I had really messed up permissions for that I fixed. Now it works.

 

Not sure how mcp/conf was messed up, I just downloaded it and then ran install.sh.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.