Jump to content

[SOLVED][1.10.2] Wavefront model texture issues (Modular Powersuits)


lehjr

Recommended Posts

I have some wavefront armor models that I'm having texture issues with. If I load and bake them manually, the texture displayed looks like it's the entire texture sheet instead of the model textures. For testing purposes, I created some dummy items and blockstate files for them, and going that route the models load fine and render fine. Any hints as to where to look to fix this would be appreciated. 

 

Models are all here: https://github.com/MachineMuse/MachineMusePowersuits/tree/1.10.2-Java/src/main/resources/assets/powersuits/models/item/armor

The working JSON files that I used to load with dummy items are here: https://github.com/MachineMuse/MachineMusePowersuits/tree/1.10.2-Java/src/main/resources/assets/powersuits/blockstates

Rendering is done through quads, starting here: https://github.com/MachineMuse/MachineMusePowersuits/blob/1.10.2-Java/src/main/java/net/machinemuse/powersuits/client/render/modelspec/RenderPart.java

and ending here: https://github.com/MachineMuse/MachineMusePowersuits/blob/1.10.2-Java/src/main/java/net/machinemuse/powersuits/client/render/modelspec/ModelPartSpec.java#L47-L63

And yes, the rest of the mod is still a bit of mess that I'm cleaning up. 

 

2017-03-06_11.42.48.png

2017-03-06_12.03.38.png

Edited by lehjr
Link to comment
Share on other sites

  • 4 weeks later...

So after digging into the model loading system it looks like the model loading is a different process than what it appears on the surface. When using JSON files to load models, textures are registered automatically in that process, but not if you load the textures yourself. There's also the OBJLoader's internal cache, which means that loading the OBJModel before the texture is registered will result in storing a broken copy of the model. This means that you won't be able to get the textures by OBJModel#getTextures() in order to register them. Of course you could just use your own loader and add a section that loads without the cache so you can use OBJModel#getTextures() to get the textures and register them. Then later on load again with the cache. 

 

So if your texture looks like this when you load the OBJ model, your mapping is lost: 

TextureAtlasSprite{name='powersuits:items/armor/diffuse', frameCount=0, rotated=false, x=0, y=0, height=0, width=0, u0=0.0, u1=0.0, v0=0.0, v1=0.0}

If it looks like this then it should work:

TextureAtlasSprite{name='powersuits:items/armor/diffuse', frameCount=1, rotated=false, x=1024, y=512, height=512, width=512, u0=0.25, u1=0.375, v0=0.25, v1=0.5}

 

Link to comment
Share on other sites

  • 4 years later...
  • Guest locked this topic
Guest
This topic is now closed to further replies.


  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • !warudo.isClientSide() still not a gui not an error just a simple message [06:44:39] [Render thread/WARN] [minecraft/MenuScreens]: Failed to create screen for menu type: mercmod:gem_polishing_menu Not a hint of what the problem is  this silent simple error dont tell much about the problem the code i made don't show errors highlighted   in mi old code 1.19.4 i launch the menu part from client side  but now i recheck the video and kapenjoe does it server side         
    • Hey, for getting your model to show up in Forge, double-check the way you've set up your model registration. Sometimes, it's just a tiny mix-up with where you've put your model file or maybe missing the right event to hook it up. Also, peek at your @Mod.EventBusSubscriber setup; it's gotta be listening in the right place. And don't forget to place your model file in the exact right spot with the correct naming. If in doubt, the Forge docs or forum threads can be super helpful.
    • Since flying mobs like bees and flies aren't affected, the problem likely lies with how ground mob AI interacts with the server environment. Checking the server logs, as you've done, is a good step. You might want to look for errors related to mob AI or pathfinding. Consider removing or updating mods one at a time to isolate the issue. Additionally, ensure your server's performance isn't being overly taxed by the modpack, as this can sometimes lead to unusual behavior with entity AI.
    • I'm having the same issue rn. Hostile mobs wont move until attacked but peaceful land mobs wont move at all. If it swims or flies its unaffected until it touches blocks.
    • Im trying to register model for my item but it doesn't works. First I Created a class where i declared all my items.   public class ModItems { public static final List<Item> ITEMS = new ArrayList<Item>(); public static final Item MY_ITEM = new MyItemClass(); } Then I created the MyItemClass where i describe my item. public class MyItemClass extends Item { public MyItemClass() { this.setRegistryName("my_item"); this.setUnlocalizedName("my_item"); this.setCreativeTab(CreativeTabs.COMBAT); ModItems.ITEMS.add(this); } } And The i created a class where i was trying register the model and where i registered my item @Mod.EventBusSubscriber public class EventsHandler { @SubscribeEvent public void registerItems(RegistryEvent.Register<Item> event) { event.getRegistry().register(new MyItemClass()); } @SubscribeEvent @SideOnly(Side.CLIENT) public static void onRegistryModel(ModelRegistryEvent event) { registryModel(new MyItemClass()); } @SideOnly(Side.CLIENT) private static void registryModel(Item item) { final ResourceLocation regName = item.getRegistryName(); final ModelResourceLocation mr1 = new ModelResourceLocation(regName, "inventory"); ModelBakery.registerItemVariants(item, mr1); ModelLoader.setCustomModelResourceLocation(item, 0, mr1); } } The registerItems method just registers my items. Then im catching ModelRegistryEvent to register my model. And in the last private method im registering models. In The game iitem still has purple-black cube instead of texture. I dont forgot to create the models\item folder and my_item.json file im sorry if this text has a grammatical errors. My english is very low  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.