Jump to content

[Solved]4x4 Crafting Matrix not registering


Sin

Recommended Posts

Never mind fixed it. Thanks anyway.

 

Hey forge community, yet another problem from me.

 

So I've made a 4x4 crafting grid which on the most part works. Any crafting done within the 3x3 of the grid works.

 

Here's the problem. Any crafting recipe utilizing the extra slots on the right most or bottom most slots (including shapeless 1 slot recipes) will not work. Even if I add a 3x3 recipe in the 3x3 part of the grid then add a block to the extension, the 3x3 will still show up, leaving me with the impression that the slots simply aren't being read to. I've struggled to find the problem for the past few days and attempted to fix it numerous times by reading through the code or looking for the rare similar problem over the net, but they are generally shots in the dark - logically speaking I can't find any interference with the 4x4. I'll post what code I have though I don't know if the problem actually resides in the custom classes.

 

-snip-

 

I gotta say, it's frustrating as hell asking for help like this but there's not a great deal of resources out there on this.

Thanks again in advance.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.