Jump to content

Can't install forge or mods?


Recommended Posts

Whenever I try to install forge or any mod, it comes out as some internet explorer jpg or jar file. When I click it just tells me to run it again and repeats. How do I solve this? I tried using another browser and that didn't work. I also tried disabling my adblockers, but that doesn't seem to work either. Any suggestions?

Link to comment
Share on other sites

Download forge from the website that you have written this post. On the top left corner, press files. Then, download. Use the installer type. (The Windows Installer.) It will be an executable jar file. With it, move it to the desktop. (Drag and take it out of the file explorer). RIght click on it and press open. It will open up an installer, agree to all the terms or whatever, and then you will have forge for the version that you want. Then, forge would have created a minecraft mods folder. From here, you can download any mod, as long as they are jar files. However, some mods require a core mod with it, such as NEI, with CodeChickenCore and the NEIuniversal jar. In this case, download both.

Edited by OfficialZanyman
Needed to add something
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.