Jump to content

[1.12] Advanced Hud


Destined

Recommended Posts

Advanced Hud

 

Hey everyone,

     Me and my friend would really love to have a mod like the one we have found called Advanced Hud allowing you to change the GUI. Now I know a bit of java and usually work with spigot developing plugins. However I am new to Forge and trying to learn it, issue is a lot of the stuff in this mod is old and updating it has become a difficult task. I have managed to rid most errors (Not that it means it was a working fix) however, there are still a few. If anyone is up for the task to update the mod themselves or help me with these last fixes, or even find an updated mod with the same capabilities. Below I will like the GitHub and if you need anything from me, let me know! 

 

Hope you don't hate me, Thank you so much!

 

Attempt at updating: https://github.com/DestinedToSuffer/AdvancedHUD
Old source GitHub: https://github.com/maxpowa/AdvancedHUD

Edited by Destined
Link to comment
Share on other sites

1.7.10 is no longer supported here, you will need to update to receive help.

 

*edit: Your build.gradle is for 1.7.10, despite the subject line saying 1.12. If people help for 1.12, odds are it will probably not work in 1.7.10 since it is so old.

Edited by Ugdhar
Link to comment
Share on other sites

6 hours ago, diesieben07 said:

Please clarify which version you are actually trying to use.

I am trying to use version 1.12 and update the mod. That is the source of the original mod from 1.7.10 and I am currently trying to update it with minimal knowledge of forge. I understand java and more regularly code plugins for spigot. The issue is I am not familiar with Forge and I have managed to figure most of it out but I am left with a few issues that I can't seem to find answers to. Was curious if someone else was either willing to just do it or help me out and I would give the source to the one I am currently working on.

Link to comment
Share on other sites

9 hours ago, Ugdhar said:

1.7.10 is no longer supported here, you will need to update to receive help.

 

*edit: Your build.gradle is for 1.7.10, despite the subject line saying 1.12. If people help for 1.12, odds are it will probably not work in 1.7.10 since it is so old.

That is the old source of the original mod, I am trying to update it to 1.12. I understand java but not familiar with the Forge API and normally code for spigot plugins. Just trying to either have someone offer help or willing to do it for me. Ill edit the post and post my source aswell of what I currently have.

Link to comment
Share on other sites

3 hours ago, Big_Bad_E said:

I looked at this mod, and it uses a lot of old methods that aren't in 1.12, so you would need to entirely recode the mod to make it 1.12. Sorry!

That's what I figured but I was hoping that I was just being an idiot, Thanks alot <3

Link to comment
Share on other sites

Updating mod versions can be a bit of a pain, but is usually possible so long as you're a decent Java programmer. You need to be good at Java because you will have to hunt for equivalent functionality which sometimes has been significantly changed. Also sometimes little things like renaming methods happens which can be a pain to track down.

 

I do give some general advice on updating mods, as well as some specific tips for updating some things in my tutorial here: http://jabelarminecraft.blogspot.com/p/minecraft-modding-updating-your-mod.html

 

My tutorial only has specific tips up to 1.10 (still working on learning the 1.12 stuff myself) but those will still apply to you as steps along the way. Hope it helps.

  • Like 2

Check out my tutorials here: http://jabelarminecraft.blogspot.com/

Link to comment
Share on other sites

16 hours ago, jabelar said:

Updating mod versions can be a bit of a pain, but is usually possible so long as you're a decent Java programmer. You need to be good at Java because you will have to hunt for equivalent functionality which sometimes has been significantly changed. Also sometimes little things like renaming methods happens which can be a pain to track down.

 

I do give some general advice on updating mods, as well as some specific tips for updating some things in my tutorial here: http://jabelarminecraft.blogspot.com/p/minecraft-modding-updating-your-mod.html

 

My tutorial only has specific tips up to 1.10 (still working on learning the 1.12 stuff myself) but those will still apply to you as steps along the way. Hope it helps.

Thanks man! I'll give it a look for sure and see if its worth trying to update. I had a few others look at it that have used forge for a couple years and they said some of the functions in that mod arent even around with replacements and use a completely different method to achieve that similar goal. Meaning you'd need alot of time and pretty much recode the entire thing. As someone who normally works with Spigot I don't know if I am up for the task... Either way I will bookmark for future endevers so thank you very much!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.