Jump to content

Tile entities randomly stop working 1.12.1


Recommended Posts

I'm putting together a custom modpack on 1.12. Most mods are ones I've used on older versions but I'm experiencing a problem that is likely mod-related, I just have no way to determine which.


Here's my modlist: https://pste.me/#/fVo33  (I've updated a few and have removed Quark since making this list)


The issue is that randomly, but regularly, machines/tile entities stop working. Furnaces stop being usable (fuel + item just won't start burning), Tinker's smeltery stops melting ores, pouring doesn't fill anything it just pours forever. Immersive Engineering capacitors stop filling, even though a water wheel is turning, etc.


I can fix these items by breaking and re-placing them, or by rebooting the server. I can't break certain blocks like the smeltery, so rebooting is the only real solution.


I don't know any way to reproduce the issue, outside of waiting for it. It used to happen regularly, every 10 minutes or so. I took out Quark due to perf issues and reports it was buggy and I thought it fixed this issue too, but after an hour of playing this morning, the issue happened again.


I can't even debug this with trial and error because if it takes up to an hour to happen, it will take way too long.


What could even cause this? Does anyone have any advice?



Link to comment
Share on other sites

Are there any unusual messages in the console?  
How much load does "Java(TM) Platform SE binary" cause to your server?
Is one core individually under much higher load than other cores?
How much ram does the server use?

How much ram did you assign to the server?

How much tps does your server have on average when the incidents occur?

Did your try to remove individual mods that might cause the problem?

Did you have any crashes before?

Are parts of the world you play on currupt?

Does your server run a modpack by another creator with similar mods without issue? (Like Feed the Beast packs for example)


Give use anything to work with...

Edited by Busti

PM's regarding modding questions should belong in the Modder Support sub-forum and won't be answered.

Link to comment
Share on other sites

No unusual messages when the issue occurs. When exploring new chunks I do see some messages "<ModName> loaded a new chunk (50, 8  Dimension: 0) during chunk population, causing cascading worldgen lag. Please report this to the mod's issue tracker. This log can be disabled in the Forge config." but the issue I've described happens even when no new chunks have been generated.


I'll have to monitor the CPU usage next time but it hasn't been unusual. I allocate 6GB of RAM to the server, 6GB to the client. The client tends to use 40% or so (according to F3), I don't know how to check what the server's using.


Since removing Quark I have 20 tps on the server all the time.


No I haven't tried to remove individual mods because with 70+ mods, no way to reproduce the issue, and sometimes up to an hour before it happens again, I'd potentially spend days debugging this. That doubles if this is a conflict between two mods rather than a single cause.


I've not had any crashes. This is a brand new world and I keep mods updated. There's no corruption.


I've run dozens of various modpacks without issue, but none of them are 1.12. Recently, I've run SkyFactory 3, a custom 1.10 tech modpack, and a few others.


I've never seen this specific issue before.

Link to comment
Share on other sites

I have seen this same behavior, and am able to reproduce it by letting the chunk unload (like going to the nether or some other dimension) and then coming back. Still not able to determine what mod/mod combination is causing this though.


EDIT: Seems the issue is with the Redstone Flux mod. No idea where to report the issue, since that mod does not have an issue tracker. Hopefully TeamCoFH responds on twitter.


EDIT: Seems to happen even with no mods installed but simply forge.

Edited by darkphan
Link to comment
Share on other sites

That's exactly my assumption - that it happens when the chunk unloads and reloads. I can't always reproduce it because I don't know when the chunk unloads, but it seem to happen very consistently when I went to another dimension and returned, ventured away and returned via teleport/death, or logged off but let the server run without me.


Is there a way to know when the chunk unloads? This problem is very annoying but no seems to have reported it, which made me feel like it was only me. If it happens with forge alone, that's big news, so I'd love to find a way to consistently reproduce it and file an issue.


I might consider adding a chunk loader to keep my chunks active, that should theoretically avoid the problem until its fixed.

Link to comment
Share on other sites

From further testing it seems to start happening after build 2450 of Forge. There is a note that might be related in that build:



mezz: Fix MC-117075 lag spike when unloading many tile entities (#4281)

That is just a hunch, but it does start happening with that build on to the current version. I rolled my server back to a build before that as a work around.

Link to comment
Share on other sites

I'd like to get an issue filed on forge but am not sure I know enough to describe it well.


So to reproduce, all you need to do is cause a chunk reload after it's been unloaded? Am I correct in saying that it causes "tile entities to stop working"? I've noticed it also affects forestry beehives, botania endoflames, etc. It's literally everything.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.