Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

OutOfBoundsException during :decompileMc


Shnupbups100
 Share

Recommended Posts

I was attempting to update my dev environment to 1.12.2 (from 1.12.1, which worked perfectly) and kept getting an error when using

gradlew setupDecompWorkspace

 

During the :decompileMc process, I would get this error:

Spoiler

:decompileMc
Exception in thread "main" java.lang.IndexOutOfBoundsException: Index: 24, Size: 9
        at java.util.ArrayList.rangeCheck(ArrayList.java:653)
        at java.util.ArrayList.get(ArrayList.java:429)
        at org.jetbrains.java.decompiler.struct.consts.ConstantPool.<init>(ConstantPool.java:109)
        at org.jetbrains.java.decompiler.struct.StructClass.<init>(StructClass.java:84)
        at org.jetbrains.java.decompiler.struct.StructClass.<init>(StructClass.java:72)
        at org.jetbrains.java.decompiler.struct.StructContext.addArchive(StructContext.java:159)
        at org.jetbrains.java.decompiler.struct.StructContext.addSpace(StructContext.java:100)
        at org.jetbrains.java.decompiler.struct.StructContext.addSpace(StructContext.java:78)
        at org.jetbrains.java.decompiler.main.Fernflower.addAllClasspath(Fernflower.java:119)
        at org.jetbrains.java.decompiler.main.Fernflower.<init>(Fernflower.java:47)
        at org.jetbrains.java.decompiler.main.decompiler.BaseDecompiler.<init>(BaseDecompiler.java:32)
        at net.minecraftforge.gradle.tasks.fernflower.FernFlowerInvoker.runFernFlower(FernFlowerInvoker.java:64)
        at net.minecraftforge.gradle.tasks.fernflower.FernFlowerInvoker.main(FernFlowerInvoker.java:41)
:decompileMc FAILED

 

 

My JAVA_HOME is correctly set, I'm using JDK 1.8 64 bit, everything worked perfectly fine just as I had it with 1.12.1.

 

Anyone know why this is happening, and if I can do anything to fix it?

Edited by Shnupbups100
Link to comment
Share on other sites

So I just came over here to ask about exact same issue that I am suddenly getting with a project that I am pretty sure I didn't get last time I updated to 1.12. 

 

For your reference the build file that I am using https://github.com/P3pp3rF1y/Reliquary/blob/1.12.x/build.gradle 

 

I suspect this issue may have something to do with a recent update to FG?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.