Jump to content

Jetpack charge resetting


Recommended Posts

I've implemented a simple Jetpack in my mod, which utilizes the damagevalue of the item to hold it's batterycharge.
The majority of the code is executed client-side, since it requires KeyInput from the player, hence I update the charge drained on the server with a custom Packet.
However, at seemingly random times, the charge of the item is reset to a higher value, for seemingly no reason. (Only tested during Multiplayer-play.)

Something that might be related is the fact that I sometime get a "ByteBuf.release() was not called before it's garbage-collected.", which I've been unable to find the reason for.

Code: https://github.com/44tim44/BetterThanElectricity_1.12.2
The jetpack itself is in item>ItemJetpack.java

The jetpack-packet is in network/PacketToServerJetpack.java


Edited by 44tim44
Link to comment
Share on other sites

I thought I was handling the packet on the main thread by using

serverPlayer.getServerWorld().addScheduledTask(() -> {
	//Insert code here


So basically, in ItemJetpack, the only thing that should happen inside

	//Insert code here

is sending a packet saying "Space is pressed"
and let onMessage() handle everything?



Okay, nevermind.
I just do it like I did before, but let the packet handle the decreasing of the charge, instead of settingCharge to what is clientSide.


Edited by 44tim44
Link to comment
Share on other sites

3 minutes ago, diesieben07 said:

I am not sure why I missed that...


That should be alright. Just don't trust the client ;)

I do think my main problem, for the bug itself, was the fact that I didn't have a unique id when registering the Packet&Handler. *facepalm*

But I still get "ByteBuf.release() was not called before it's garbage-collected." in my stacktrace from time to time.
Is that because of something I did wrong? Because I can't find anyone else with the same problem on google (relating to minecraft).

Edited by 44tim44
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • !warudo.isClientSide() still not a gui not an error just a simple message [06:44:39] [Render thread/WARN] [minecraft/MenuScreens]: Failed to create screen for menu type: mercmod:gem_polishing_menu Not a hint of what the problem is  this silent simple error dont tell much about the problem the code i made don't show errors highlighted   in mi old code 1.19.4 i launch the menu part from client side  but now i recheck the video and kapenjoe does it server side         
    • Hey, for getting your model to show up in Forge, double-check the way you've set up your model registration. Sometimes, it's just a tiny mix-up with where you've put your model file or maybe missing the right event to hook it up. Also, peek at your @Mod.EventBusSubscriber setup; it's gotta be listening in the right place. And don't forget to place your model file in the exact right spot with the correct naming. If in doubt, the Forge docs or forum threads can be super helpful.
    • Since flying mobs like bees and flies aren't affected, the problem likely lies with how ground mob AI interacts with the server environment. Checking the server logs, as you've done, is a good step. You might want to look for errors related to mob AI or pathfinding. Consider removing or updating mods one at a time to isolate the issue. Additionally, ensure your server's performance isn't being overly taxed by the modpack, as this can sometimes lead to unusual behavior with entity AI.
    • I'm having the same issue rn. Hostile mobs wont move until attacked but peaceful land mobs wont move at all. If it swims or flies its unaffected until it touches blocks.
    • Im trying to register model for my item but it doesn't works. First I Created a class where i declared all my items.   public class ModItems { public static final List<Item> ITEMS = new ArrayList<Item>(); public static final Item MY_ITEM = new MyItemClass(); } Then I created the MyItemClass where i describe my item. public class MyItemClass extends Item { public MyItemClass() { this.setRegistryName("my_item"); this.setUnlocalizedName("my_item"); this.setCreativeTab(CreativeTabs.COMBAT); ModItems.ITEMS.add(this); } } And The i created a class where i was trying register the model and where i registered my item @Mod.EventBusSubscriber public class EventsHandler { @SubscribeEvent public void registerItems(RegistryEvent.Register<Item> event) { event.getRegistry().register(new MyItemClass()); } @SubscribeEvent @SideOnly(Side.CLIENT) public static void onRegistryModel(ModelRegistryEvent event) { registryModel(new MyItemClass()); } @SideOnly(Side.CLIENT) private static void registryModel(Item item) { final ResourceLocation regName = item.getRegistryName(); final ModelResourceLocation mr1 = new ModelResourceLocation(regName, "inventory"); ModelBakery.registerItemVariants(item, mr1); ModelLoader.setCustomModelResourceLocation(item, 0, mr1); } } The registerItems method just registers my items. Then im catching ModelRegistryEvent to register my model. And in the last private method im registering models. In The game iitem still has purple-black cube instead of texture. I dont forgot to create the models\item folder and my_item.json file im sorry if this text has a grammatical errors. My english is very low  
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.