Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

supress xp orbs <update>


acecase
 Share

Recommended Posts

After overcomplicating this thing several different ways, I see that I can simply set the experienceValue for the entity passed to my handler by the onLivingDeath event.

 

This works for hostile mobs. Now I just need to figure out why it isn't working for passive mobs.

 

EntityPig extends EntityAnimal extends EntityAgeable extends EntityCreature extends EntityLiving

EntityLiving is where the method onDeathUpdate() exists, which is the method that spawns the EntityXPOrb, so I'm guessing one of these other classes is overriding something.

Link to comment
Share on other sites

Thank you. I can suppress all xp orbs easy enough within that event by checking that the name is "Experience Orb" and setting Event.setCanceled to true. The problem with this method is that I can't distinguish between a potion of enchanting, smelting xp, etc, and the mob dropped xp. Or at least I don't see a way. I was hoping there would be a way to see the source or dropping entity or something.

 

Link to comment
Share on other sites

You could try using LivingDeathEvent and setting EntityLiving.experienceValue to 0 for the dying entity.

 

This actually does work, but it has a "bug?" or something. I tried it this way first, but it didn't suppress the orbs. I was testing it on pigs. It turns out, this works fine on hostile mobs, but not on passive mobs.

 

It should work, as the EntityPig class extends the EntityAnimal class, which extends the EntityAgeable class, which extends the EntityCreature class, which extends the EntityLiving class, and EntityLiving class is where the method onDeathUpdate() exists, which is what spawns the EntityXPOrbs when mobs die.

 

I haven't looked at all of these classes to see if something is being overridden or anything though.

 

Just wanted to clarify that you were in fact correct.

 

Thank you again.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
    • Okay, i think i understand but im getting issues, i create another packet to sync entity to another players like this package com.naim.belloto.networking.packet; import com.naim.belloto.networking.handler.ClientSyncHandler; import net.minecraft.client.Minecraft; import net.minecraft.network.FriendlyByteBuf; import net.minecraftforge.api.distmarker.Dist; import net.minecraftforge.fml.DistExecutor; import net.minecraftforge.network.NetworkEvent; import java.util.Objects; import java.util.function.Supplier; public class ClientSyncPacket { public ClientSyncPacket() { } public ClientSyncPacket(FriendlyByteBuf buf) { } public void toBytes(FriendlyByteBuf buf) { } public boolean handle(Supplier<NetworkEvent.Context> ctx) { NetworkEvent.Context context = ctx.get(); context.enqueueWork(() -> { assert Minecraft.getInstance().player != null; int idplayer = Minecraft.getInstance().player.getId(); DistExecutor.unsafeCallWhenOn(Dist.CLIENT,() -> () -> ClientSyncHandler.handlePacket(ctx, idplayer)); }); return true; } } And in the handler: public class ClientSyncHandler { public static boolean handlePacket(Supplier<NetworkEvent.Context> ctx, int idPlayer) { Minecraft.getInstance().level.getEntity(idPlayer); return true; } } But is not working :// 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.