Jump to content

1.12 How do I get the location and direction of a model part?


TheRPGAdventurer

Recommended Posts

Sorry but you just have to work it out. Based on how your model is built up and animates you'll have to do all the trigonometry involved. It might be easiest to actually draw it out on paper and figure it out. But basically you need to start from the body position and depending on the rotation figure out where the neck attaches, and then based on the neck rotation figure out where the head attaches, and then based on the head rotation figure out where the mouth would be.

Check out my tutorials here: http://jabelarminecraft.blogspot.com/

Link to comment
Share on other sites

public class Point3d {

	public double x, y, z;
	
	public Point3d(double x, double y, double z) {
		this.x = x;
		this.y = y;
		this.z = z;
	}
	
	public double distance(Point3d p) {
		return Math.sqrt(Math.pow(p.z - this.z, 2) + Math.pow(Math.sqrt(Math.pow(p.x - this.x, 2) + Math.pow(p.y - this.y, 2)), 2));
	}
	
	/**Rotates the point around the given {@code rotationCentre}
	 * with the given {@code jaw} and {@code pitch}
	 * The vertical rotation ({@code pitch}) will be done after the horizontal rotation ({@code jaw}),
	 * over the x axis that is first rotated over the y axis by {@code pitch} radians.
	 * <p>
	 * @param rotationCentre - what does it say?
	 * @param pitch - the vertical rotation angle
	 * @param jaw - the horizontal rotation angle
	 * @return the Point3d that is calculated to be the position of this point after the rotations
	 * and changes the location of this point to the return value
	 */
	public Point3d rotate(Point3d rotationCentre, double pitch, double jaw) {
		double d = this.distance(rotationCentre);
		Point3d firstRotationPoint = new Point3d(
				rotationCentre.x + (d * Math.cos(jaw)),
				this.y,
				rotationCentre.z + (d * Math.sin(jaw))
				);
		this.x = rotationCentre.x + (firstRotationPoint.x - rotationCentre.x) * Math.cos(pitch);
		this.y = rotationCentre.y + (d * Math.sin(pitch));
		this.z = rotationCentre.z + (firstRotationPoint.z - rotationCentre.z) * Math.cos(pitch);
		return new Point3d(
				rotationCentre.x + (firstRotationPoint.x - rotationCentre.x) * Math.cos(pitch),
				rotationCentre.y + (d * Math.sin(pitch)),
				rotationCentre.z + (firstRotationPoint.z - rotationCentre.z) * Math.cos(pitch)
				);
	}
}

Ok, this is really only useful for calculating the position of 1 of the rotation points, that is, if and only if the dragon hasn't rotated their entire body. I'm working on a formula to make it relative to previous rotations of parent parts, but that might take some time, I'll try my best to get it done.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Please share a link to your crash report on https://paste.ee, as explained in the FAQ. Dumping it directly into the thread often triggers the anti-spam and makes it hard to read due to word wrapping
    • Hi all, I'm running a 1.20.1 Minecraft Forge server with a hosting website and something seems to have gone wrong. It started as an occasional crash that has now become extremely frequent and I don't know what exactly is causing it. I already tried disabling watchdog but the server crashes anyway. Oddly it only occasionally generates a crash report after a crash occurs. Based on viewing the server console's research usage it seems that the CPU spikes astronomically high (100% usage), especially when chunks are being loaded or when a new person joins the server. I downloaded Spark to create a profile (https://spark.lucko.me/bBlWe7ou29) but I lack experience with this mod and don't understand what I'm looking at/how this should help me diagnose the issue. I am using a lot of mods so I'm guessing there is some sort of issue there or a corrupted chunk (although MCRF found no chunk errors). We actually don't experience any lag until the crash occurs, so it's some sort of sudden spike in resource usage. Based on the crash report I've already tried removing Canary and Modernfix but there was no change. Thanks for any help you can provide. Specs:  4 cores x 4200MHz AMD Ryzen 9 5950X 4GB RAM Crash report:  
    • will test that once i get home, thanks
    • I am getting this exception (I am new and just trying to create an item) Caused by: java.io.FileNotFoundException: abrasmagics:models/item/ingot_test.json at net.minecraft.client.resources.SimpleReloadableResourceManager.getResource(SimpleReloadableResourceManager.java:69) ~[SimpleReloadableResourceManager.class:?] at net.minecraft.client.renderer.block.model.ModelBakery.loadModel(ModelBakery.java:334) ~[ModelBakery.class:?] at net.minecraftforge.client.model.ModelLoader.access$1400(ModelLoader.java:115) ~[ModelLoader.class:?] at net.minecraftforge.client.model.ModelLoader$VanillaLoader.loadModel(ModelLoader.java:861) ~[ModelLoader$VanillaLoader.class:?] at net.minecraftforge.client.model.ModelLoaderRegistry.getModel(ModelLoaderRegistry.java:157) ~[ModelLoaderRegistry.class:?]   However the directory is set up correctly and the file does exist   idk how to upload images so here is a treeview of the directories:   src ├───main │ ├───java │ │ └───net │ │ └───abrasmods │ │ └───abrasmagics │ │ ├───init │ │ ├───items │ │ └───utils │ │ ├───handlers │ │ ├───misc │ │ └───proxy │ └───resources │ └───assets │ └───abrasmagics │ ├───models │ │ ├───block │ │ └───item │ └───textures └───test ├───java └───resources   the file ingot_test.json is under models/item. The directory seems fine and the file does exist so anyone plz help.   i am using intellij and is coding for 1.12.2
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.