Jump to content

setupDecompWorkspace and genIntellijRuns are not working


Recommended Posts

im using the latest version of forge at the moment for 1.12.2, im just re writing my mod....
ive done this many times before and never had this issue.
i have no external libraries and or anything in the run folder
steps i take when making  an environment
1) make folder

2) add mdk to folder, then extract the mdk (currently using "forge-1.12.2-")

3) double click build.gradle

    deselect "create seperate module per source set" because i do not need more than one.

    set jdk to the proper 1.8.0_172

    click ok

4) project opens in intellij and i open the gradle on the right then select the setupDecompWorkspace and edit the vm to be 1gig to 7 gigs
then runit, then it says no errors.

5) go back to folder and run the dradlew.bat (only need to do this once, but i did it every time i make the environment.)

6) return to intellij and configure the genIntellijRuns then run it and no errors, yet i have no run files or minecraft libraries.

im confused, ive never had this problem.

video of me showing you what i am talking about, although i cant post logs for i have none...

minecraft modded environment without the environment...

Link to comment
Share on other sites

that was an instance that i had already setup, i did refresh when i set it up, i just remade my instance and the run folder wasnt showing anything, its not a lack of knowledge on my part (for once). before i left for work, i redid the whole thing and i still didnt have a run folder or the minecraft libraries, then i ran minecraft.exe and the folder showed up. i did the install in the exact order that the forge forums says this time for sure. no way of doing things different because i read from top to bottm, i did not do anything different than i normally would so thats a relief.

my folder was empty, untill i tried running minecraft. i mean in intellij and in the mod environment folder. the refresh icon on the gradle panel does jackshit after i sync the gradle project. and it still does nothing if i only refresh and do not sync the project.
the libraries and minecraft run folder only show up when ive tried to run minecraft.

sorry for the delay in messaging, i fell asleep in my chair not long after the post.
i believe my intellij is messed up and im going to reinstall it when i get home.
i only have 2 hours a day i can be at the computer, kinda wish i had more spare time. more if i dont sleep.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.