Jump to content

Bug: food items in bowl do not get consumed


Streetwind

Recommended Posts

Latest.log from a trial run with only Forge, and one mod (Food Expansion) that adds some additional foods in bowls, for testing purposes: https://pastebin.com/MmKuUxdM

However, no additional mod is required for reproduction.

 

Reproduction steps:

 

* Create new world
* Give yourself a food in a bowl (f.ex. vanilla mushroom stew)
* Whittle down your hunger bar so you can eat
* Consume the food

 

Expected result:

 

Your hunger is restored, the food item is removed, and a bowl is returned to your inventory.

 

Actual result:
 

Your hunger is restored, but the food item remains where it is and can be consumed again. Sometimes a bowl is added to your inventory, but only rarely - the vanilla mushroom stew seems to do this more often than the modded foods I tried (but that's anecdotal evidence at best).

 

Research performed:

 

I did not have this issue in my previous playthrough, so as a first step, i removed all mods from this instance that were not in my previous one. This did not fix the issue.
As a next step, I removed all mods from this instance, completely. This did not fix the issue.

The only thing left to do at this point was downgrading Forge from 2760, which I was currently using, to 2705, which I used in my previous playthrough. Here, the issue disappeared.
Finally, I tried with the latest recommended build (2768) and the latest build (2772), and in both cases, the issue could be reproduced.

 

I also consumed a milk bucket. It was correctly removed and correctly returned a bucket. So far it only seems to affect foods in wooden bowls, but since I cannot even hope to speculate about the root cause, I can't discount the possibility that other consumables might also do this.

 

Hope this helps! :)

 

Edited by Streetwind
Link to comment
Share on other sites

Note:
Empty bowls can be duplicated by having the food item in Slot 2-9, and having an empty slot in any slot to the left of the food item. You will eat, Sometimes it'll visually complete, You'll get an empty bowl, But you'll also get an Actual empty bowl in the empty slot. This basically allows you to eat and run at full speed.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Issue with the player skills mod. Looks like it needs the KubeJS mod installed?
    • ---- Minecraft Crash Report ---- // Don't do that. Time: 25.03.2023, 11:31 Description: Exception in server tick loop java.lang.NoClassDefFoundError: dev/latvian/mods/kubejs/KubeJSPlugin     at java.lang.ClassLoader.defineClass1(Native Method) ~[?:?] {}     at java.lang.ClassLoader.defineClass(ClassLoader.java:1012) ~[?:?] {}     at cpw.mods.cl.ModuleClassLoader.readerToClass(ModuleClassLoader.java:116) ~[securejarhandler-1.0.3.jar:?] {}     at cpw.mods.cl.ModuleClassLoader.lambda$findClass$16(ModuleClassLoader.java:216) ~[securejarhandler-1.0.3.jar:?] {}     at cpw.mods.cl.ModuleClassLoader.loadFromModule(ModuleClassLoader.java:226) ~[securejarhandler-1.0.3.jar:?] {}     at cpw.mods.cl.ModuleClassLoader.findClass(ModuleClassLoader.java:216) ~[securejarhandler-1.0.3.jar:?] {}     at cpw.mods.cl.ModuleClassLoader.loadClass(ModuleClassLoader.java:132) ~[securejarhandler-1.0.3.jar:?] {}     at java.lang.ClassLoader.loadClass(ClassLoader.java:520) ~[?:?] {}     at net.impleri.playerskills.PlayerSkillsEvents.beforeServerStart(PlayerSkillsEvents.java:70) ~[player-skills-1.18.2-1.0.0.jar%2394!/:?] {re:classloading}     at dev.architectury.event.forge.EventHandlerImplCommon.event(EventHandlerImplCommon.java:403) ~[architectury-4.11.89-forge.jar%2358!/:?] {re:classloading}     at net.minecraftforge.eventbus.ASMEventHandler_356_EventHandlerImplCommon_event_ServerAboutToStartEvent.invoke(.dynamic) ~[?:?] {}     at net.minecraftforge.eventbus.ASMEventHandler.invoke(ASMEventHandler.java:85) ~[eventbus-5.0.3.jar%232!/:?] {}     at net.minecraftforge.eventbus.EventBus.post(EventBus.java:302) ~[eventbus-5.0.3.jar%232!/:?] {}     at net.minecraftforge.eventbus.EventBus.post(EventBus.java:283) ~[eventbus-5.0.3.jar%232!/:?] {}     at net.minecraftforge.server.ServerLifecycleHooks.handleServerAboutToStart(ServerLifecycleHooks.java:86) ~[forge-1.18.2-40.2.0-universal.jar%23124!/:?] {re:classloading}     at net.minecraft.client.server.IntegratedServer.m_7038_(IntegratedServer.java:63) ~[client-1.18.2-20220404.173914-srg.jar%23119!/:?] {re:mixin,pl:runtimedistcleaner:A,re:classloading,pl:mixin:APP:mixins.essential.json:server.integrated.MixinIntegratedServer,pl:mixin:A,pl:runtimedistcleaner:A}     at net.minecraft.server.MinecraftServer.m_130011_(MinecraftServer.java:661) ~[client-1.18.2-20220404.173914-srg.jar%23119!/:?] {re:mixin,pl:accesstransformer:B,re:classloading,pl:accesstransformer:B,pl:mixin:APP:balm.mixins.json:MinecraftServerMixin,pl:mixin:APP:mixins.essential.json:server.MinecraftServerMixin_PvPGameRule,pl:mixin:APP:mixins.essential.json:server.Mixin_PublishServerStatusResponse,pl:mixin:A}     at net.minecraft.server.MinecraftServer.m_177918_(MinecraftServer.java:261) ~[client-1.18.2-20220404.173914-srg.jar%23119!/:?] {re:mixin,pl:accesstransformer:B,re:classloading,pl:accesstransformer:B,pl:mixin:APP:balm.mixins.json:MinecraftServerMixin,pl:mixin:APP:mixins.essential.json:server.MinecraftServerMixin_PvPGameRule,pl:mixin:APP:mixins.essential.json:server.Mixin_PublishServerStatusResponse,pl:mixin:A}     at java.lang.Thread.run(Thread.java:833) [?:?] {re:mixin} Caused by: java.lang.ClassNotFoundException: dev.latvian.mods.kubejs.KubeJSPlugin     at jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:641) ~[?:?] {}     at java.lang.ClassLoader.loadClass(ClassLoader.java:520) ~[?:?] {}     at cpw.mods.cl.ModuleClassLoader.loadClass(ModuleClassLoader.java:134) ~[securejarhandler-1.0.3.jar:?] {}     at java.lang.ClassLoader.loadClass(ClassLoader.java:520) ~[?:?] {}     at cpw.mods.cl.ModuleClassLoader.loadClass(ModuleClassLoader.java:134) ~[securejarhandler-1.0.3.jar:?] {}     at java.lang.ClassLoader.loadClass(ClassLoader.java:520) ~[?:?] {}     ... 19 more  
    • You might be able to make it work by using the sound directly? i.e. something like: SoundInstance sound = new SimpleSoundInstance(...); Minecraft.getInstance().getSoundManager().play(sound); But I guess you would need to use an AccessTransformer to make the SimpleSoundInstance constructor that takes a ResourceLocation instead of a SoundEvent publicly accessible. https://forge.gemwire.uk/wiki/Access_Transformers
    • Use java 17. Mixin does not support java 20 (which only came out last week).
    • From what I understand (which might be incorrect, I am not an expert on this), it doesn't use the local client registry for those registries that have data sent from a multiplayer server. SoundEvents is one of those registries. So in multiplayer your SoundEvent effectively won't exist unless it is also registered on the server?   The logic can be found here (and its related methods): https://github.com/MinecraftForge/MinecraftForge/blob/bb49b9e6dc7525ae0fa935abf6eec18b36091bd6/src/main/java/net/minecraftforge/registries/GameData.java#L656
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.