Jump to content

[SOLVED] Serverside giving the wrong results


hiotewdew

Recommended Posts

I'm making a land claiming mod, and when using the claim tool it checks for overlaps. I got all the overlapping code down and it works fine, but the server thread returns that the block overlaps a claim even if there are NO CLAIMS in the world, and the main thread returns the proper result.

See the line commented where it prints "overlaps". The server is completely off for no apparent reason.

@Override
	public EnumActionResult onItemUse(EntityPlayer player, World worldIn, BlockPos pos, EnumHand hand,
			EnumFacing facing, float hitX, float hitY, float hitZ) {
		ItemStack stack = player.getHeldItem(hand);
		NBTTagCompound data = stack.getTagCompound();
		if(data == null) {
			NBTTagCompound newTag = new NBTTagCompound();
			data = newTag;
			stack.setTagCompound(newTag);
		}
		boolean isInClaim = ClaimManager.getManager().isBlockInAnyClaim(pos, worldIn);
		System.out.println("Overlaps: " + isInClaim); // THIS IS THE LINE WHERE THE SERVER THREAD IS WRONG
		if(!isInClaim) {
			int[] posArray = {pos.getX(), pos.getZ()};
			if(data.hasKey("Corner1")) {
				if(!worldIn.isRemote)
					player.sendMessage(new TextComponentString("Added corner 2 at " + posArray[0] + ", " + posArray[1]));
				int[] corner1 = data.getIntArray("Corner1");
				int[] corner2 = posArray;
				BlockPos c1 = new BlockPos(corner1[0], 0, corner1[1]);
				BlockPos c2 = new BlockPos(corner2[0], 0, corner2[1]);
				/* Not needed due to ClaimArea constructor
					if(c1.subtract(c2).getX() < 0 && c1.subtract(c2).getY() < 0) {
						BlockPos c = c1; // Swap values to make c1 the proper corner
						c1 = c2;
						c2 = c;
					}*/
				BlockPos sideL = c2.subtract(c1); // Subtract to get side lengths
				// Claim corners are automatically corrected to proper values by constructor
				ClaimArea newClaim;
				newClaim = new ClaimArea(player.dimension, c1.getX(), c1.getZ(), sideL.getX(), sideL.getZ(), player);
				boolean didClaim = ClaimManager.getManager().addClaim(newClaim); // Add claim
				if(!worldIn.isRemote)
					player.sendMessage(new TextComponentString(didClaim ? "Claim added successfully!" : "This claim overlaps another claim!"));
				// Remove data so a new claim can be made.
				data.removeTag("Corner1");
				return didClaim ? EnumActionResult.SUCCESS : EnumActionResult.FAIL;
			} else {
				data.setIntArray("Corner1", posArray);
				if(!worldIn.isRemote)
					player.sendMessage(new TextComponentString("Added corner 1 at " + posArray[0] + ", " + posArray[1]));
			}
			return EnumActionResult.SUCCESS;
		} else {
			if(!worldIn.isRemote) {
				data.removeTag("Corner1");
				player.sendMessage(new TextComponentString("You cannot set a corner inside an existing claim!"));
			}
		}
		return EnumActionResult.FAIL;
	}

I know this is not nearly enough code to represent the problem, so here is my source

I'm not sure how I should be doing the checking to insure that the server does all the work, and the client recieves such, but also having it work properly on SP.

This error shows up on SP, I haven't tested on an actual server.

Edited by hiotewdew
solved
Link to comment
Share on other sites

27 minutes ago, hiotewdew said:

I'm not sure how I should be doing the checking to insure that the server does all the work, and the client recieves such, but also having it work properly on SP.

There is not much difference between SP and MP since you have a server and a connection in both cases. Do your logic on the server and send the packets to the client(if needed).

 

35 minutes ago, hiotewdew said:

the server thread returns that the block overlaps a claim even if there are NO CLAIMS in the world

I am unable to replicate this issue with the code you've provided.

 

Quote

EntityPlayer.getOfflineUUID(ownerName);

This will break as soon as the player changes their name. Use their profile's UUID.

 

Link to comment
Share on other sites

On 11/18/2018 at 2:09 AM, V0idWa1k3r said:

I am unable to replicate this issue with the code you've provided

 

Did you test this on a singleplayer world?

Link to comment
Share on other sites

  • 4 weeks later...

Don't mean to necro, but it turns out all I had to do was put and if(!world.isRemote) {} check in general.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Announcements



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I am getting an error message that my mods and my server are not on the same minecraft version when they clearly are. My server and my mods are on 1.20.1 and the error says that the server is 1.20 even though it's on forge 47.2.30.  
    • .Omg, I'm so freaking blind I didn't notice that, it works now, thank you so much @Xoroshio
    • On the one off the last lines of code you have put && boots.isEmpty() Instead of && !boots.isEmpty() is that a typo?
    • I'm trying to apply effects to the emerald armor but it doesn't work, I read that the onArmorTick() method doesn't work anymore, but I tried with inventoryTick, onInventoryTick and onArmorTick but they don't apply the effect either, I don't know if I'm writing it wrong, so I need help to fix it. This is the code in question: public class ModArmorItem extends ArmorItem{ private static final Map<ArmorMaterial, MobEffectInstance> MATERIAL_TO_EFFECT_MAP = (new ImmutableMap.Builder<ArmorMaterial, MobEffectInstance>()) .put(ModArmorMaterials.EMERALD, new MobEffectInstance( MobEffects.HERO_OF_THE_VILLAGE, 200, 1, false, false, true)) .build(); public ModArmorItem(ArmorMaterial pMaterial, Type pType, Properties pProperties) { super(pMaterial, pType, pProperties); } @Override public void onArmorTick(ItemStack stack, Level world, Player player){ if (!world.isClientSide()) { if (hasFullSuitOfArmorOn(player)) { evaluateArmorEffects(player); } } } private void evaluateArmorEffects(Player player) { for (Map.Entry<ArmorMaterial,MobEffectInstance> entry : MATERIAL_TO_EFFECT_MAP.entrySet()){ ArmorMaterial mapArmorMaterial = entry.getKey(); MobEffectInstance mapStatusEffect = entry.getValue(); if (hasCorrectArmorOn(mapArmorMaterial, player)) { addStatusEffectForMaterial(player, mapArmorMaterial, mapStatusEffect); } } } private void addStatusEffectForMaterial(Player player, ArmorMaterial mapArmorMaterial, MobEffectInstance mapStatusEffect) { boolean hasPlayerEffect = player.hasEffect(mapStatusEffect.getEffect()); if (hasCorrectArmorOn(mapArmorMaterial, player) && !hasPlayerEffect) { player.addEffect(new MobEffectInstance(mapStatusEffect)); } } private boolean hasCorrectArmorOn(ArmorMaterial material, Player player) { for (ItemStack armorStack : player.getInventory().armor){ if (!(armorStack.getItem() instanceof ArmorItem)) { return false; } } ArmorItem helmet = ((ArmorItem)player.getInventory().getArmor(3).getItem()); ArmorItem brestplace = ((ArmorItem)player.getInventory().getArmor(2).getItem()); ArmorItem leggins = ((ArmorItem)player.getInventory().getArmor(1).getItem()); ArmorItem boots = ((ArmorItem)player.getInventory().getArmor(0).getItem()); return helmet.getMaterial() == material && brestplace.getMaterial() == material && leggins.getMaterial() == material && boots.getMaterial() == material; } private boolean hasFullSuitOfArmorOn(Player player){ ItemStack helmet = player.getInventory().getArmor(3); ItemStack breastplace = player.getInventory().getArmor(2); ItemStack leggins = player.getInventory().getArmor(1); ItemStack boots = player.getInventory().getArmor(0); return !helmet.isEmpty() && !breastplace.isEmpty() && !leggins.isEmpty() && boots.isEmpty(); } } And here is the armor   public static final RegistryObject<Item> EMERALD_HELMET = ITEMS.register( "emerald_helmet", () -> new ModArmorItem(ModArmorMaterials.EMERALD, ArmorItem.Type.HELMET, new Item.Properties()) ); public static final RegistryObject<Item> EMERALD_CHESTPLATE = ITEMS.register( "emerald_chestplate", () -> new ModArmorItem(ModArmorMaterials.EMERALD, ArmorItem.Type.CHESTPLATE, new Item.Properties()) ); public static final RegistryObject<Item> EMERALD_LEGGINS = ITEMS.register( "emerald_leggins", () -> new ModArmorItem(ModArmorMaterials.EMERALD, ArmorItem.Type.LEGGINGS, new Item.Properties()) ); public static final RegistryObject<Item> EMERALD_BOOTS = ITEMS.register( "emerald_boots", () -> new ModArmorItem(ModArmorMaterials.EMERALD, ArmorItem.Type.BOOTS, new Item.Properties()) ); I hope you can help me. Thanks.
    • so ive been having this issue for a little bit, and have honestly no clue on how to fix it. I'm using minecraft 1.20.1 for clarification.  Here is the latest log: https://pastebin.com/neMuxELv
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.