Jump to content

[1.13.2] [SOLVED] Trouble getting Forge Blockstate JSON to work


Recommended Posts


I've been trying to get Forge's blockstates to work with my mod to save some time with the blockstate files.


I added the file assets/minecraft/blockstates/acacia_slab.json to my mod resources but it doesn't work: the placed acacia slabs just display the standard purple/black cubes.



	"forge_marker": 1,
	"defaults": {
		"textures": {
			"top" : "minecraft:block/acacia_log_top",
			"side" : "minecraft:block/acacia_log",
			"bottom" : "minecraft:block/acacia_log_top",
			"end" : "minecraft:block/acacia_log_top"
    "variants": {
		"type": {
			"bottom" : { "model": "minecraft:block/slab" },
			"top" : { "model": "minecraft:block/slab_top" },
			"double" : { "model": "minecraft:block/column" }


I tried a lot of stuff with this. Even if I just copy the default file and only add "forge_marker": 1, it still displays the broken model.


Where did I go wrong? I have not found anything about these Blockstates not working at all on 1.13.

Edited by TheOnlyTrueEnte
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.