Jump to content

Need help installing Forge on Linux Fedora


Recommended Posts

I am currently trying to install Forge onto my computer. I run 64-bit Fedora 29.

I downloaded the forge installer .jar file, and tried to run it from terminal using the java -jar jarfile command. I've done this before, and it worked - however I've reinstalled the OS since then and I've had trouble running jar files for some reason.

When I execute the command, the system creates a .jar.log file and this is the output:

Exception in thread "main" 
	at java.awt.GraphicsEnvironment.checkHeadless(GraphicsEnvironment.java:204)
	at java.awt.Window.<init>(Window.java:536)
	at java.awt.Frame.<init>(Frame.java:420)
	at net.minecraftforge.installer.InstallerPanel.run(InstallerPanel.java:411)
	at net.minecraftforge.installer.SimpleInstaller.launchGui(SimpleInstaller.java:162)
	at net.minecraftforge.installer.SimpleInstaller.main(SimpleInstaller.java:135)

I checked the properties of the jarfile and the permission to allow it to execute as a program is checked, and it still won't run the installer.

Does anybody know how to fix this?


EDIT: Apparently this is an issue with Linux using two versions of java. Ran the command $ sudo dnf install java-1.8.0-openjdk, seems to work fine now.

Edited by graypluto
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.