Jump to content

1.14.2 missing block under custom model


Recommended Posts

im very new to modelling so this is very hard for me to do,

anyways my problem is when i place my custom model down, the block below misses its top side,

im aware minecraft does this because it thinks that it is a full block and it wouldnt normally render.

i know  people have already "fixed" this but it never seems to work, and when i do get the code i need, im totally clueless to know where

to put it.


Link to comment
Share on other sites

The title of your post suggests you are using 1.14.2. Please clarify what version are you actually using. And whether you are using forge at all.


5 minutes ago, Ywes said:

and your Model .json file

This has nothing to do with the model file of either of the blocks. OP just needs to override Block#isFullCube and Block#isOpaqueCube to return false.

Link to comment
Share on other sites

On 5/31/2019 at 11:39 AM, V0idWa1k3r said:

For propagating light either override Block#isOpaqueCube or

It changed to isSolid in 1.13

About Me


My Discord - Cadiboo#8887

My WebsiteCadiboo.github.io

My ModsCadiboo.github.io/projects

My TutorialsCadiboo.github.io/tutorials

Versions below 1.14.4 are no longer supported on this forum. Use the latest version to receive support.

When asking support remember to include all relevant log files (logs are found in .minecraft/logs/), code if applicable and screenshots if possible.

Only download mods from trusted sites like CurseForge (minecraft.curseforge.com). A list of bad sites can be found here, with more information available at stopmodreposts.org

Edit your own signature at www.minecraftforge.net/forum/settings/signature/ (Make sure to check its compatibility with the Dark Theme)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.