Jump to content

Mods not showing up in Forge 1.14.4 (28.0.38)


Recommended Posts

Hello. I have a problem with mods not showing up in the game. I am on version MC 1.14.4 and Forge 28.0.38. I know I don't hgave the latest version of Forge for 1.14.4 but the latest version didn't work either so I wanted to see if a older version worked, the answer was no, if you couldn't tell. I got 2 of the mods from planetminecraft.com and the download button redirected me to chocolateminecraft.com to download them. Another one of the mods was Optifine, I downloaded that from optifine.net. The last mod I got from minecraftcapes.co.uk for a cape mod. I included a screenshot of my 1.14.4 mods folder too.


Link to comment
Share on other sites

Okay, I removed Optifine and the remaining 3 mods for 1.14.4 still didn't load. Also, I don't know what you mean by, "Mods must be placed in the mods folder, not a subfolder." (I am still very new at this) I had the 1.14.4 mod folder in the mods folder because I heard that Forge can load mods for the correct MC version that way. I also tried just having those three mods at the root of the folder with nothing else in there (no mods or folders) and the game crashed saying, "An unexpected issue occurred and the game has crashed. We're sorry for the inconvenience."

Link to comment
Share on other sites

55 minutes ago, diesieben07 said:

This is not true anymore. Use the game directory setting in your launcher to separate different versions.

Alright, I'm not sure if you mean use the game directory setting when editing/creating a new installation of a MC version in the launcher or something else. Please expand more on that.

1 hour ago, diesieben07 said:

Post logs.

I'm pretty sure this is the log you are looking for.


Link to comment
Share on other sites

Okay, so I kinda fixed the problem. I updated Forge and when I launched the game, it still didn't show the mods. So, I was messing around with the game directory settings. When I removed the original mods folder from the .minecraft folder, it made another mods folder. (as it should) When I put the 1.14.4 mods in the new mods folder, they loaded! Now this is where the "kinda fixed" part is. When I put them in a 1.14.4 folder inside the mods folder, they suddenly didn't load anymore. But when I pulled them out, deleted the folder and left the mods on the root of the mods folder, they loaded in again. This may just be a bug, since Forge for 1.14.4 is still a beta.

Link to comment
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.