Jump to content

[SOLVED] Mod crashes forge server on startup


colenobi

Recommended Posts

7 minutes ago, colenobi said:

 here is the error message whenever I try to load the server in eclipse.

Any and all rendering code must be done on the client only.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

7 minutes ago, colenobi said:

okay, so what am I supposed to do then? like I said earlier, I haven't done modding in a few years

There is a lot that needs to be done.

First off remove IHasModel, BlockBase and ItemBase. All Items have models, and there is already a base Item and Block class. They are called Item and Block. Don't use inheritance for code-reuse. It's an anti-pattern.

The main problem comes from you calling RenderHandler.someMethodHere in common code. If you are gonna call Client code from a common code class/method you need to use the @SidedProxy system. Route the code through them.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

3 minutes ago, colenobi said:

Okay, I fixed the issue, I had to add


@SideOnly(Side.CLIENT)

Over both Overrides here.

That's not what you are supposed to do that will still crash the dedicated server.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

31 minutes ago, Animefan8888 said:

That's not what you are supposed to do that will still crash the dedicated server.

I just set up a new server on my laptop, put a few extra mods on there, played around in creative mode for a while, and no crashes. So, yeah. The issue is fixed

Link to comment
Share on other sites

4 minutes ago, colenobi said:

I just set up a new server on my laptop, put a few extra mods on there, played around in creative mode for a while, and no crashes. So, yeah. The issue is fixed

I'm just gonna link this.

VANILLA MINECRAFT CLASSES ARE THE BEST RESOURCES WHEN MODDING

I will be posting 1.15.2 modding tutorials on this channel. If you want to be notified of it do the normal YouTube stuff like subscribing, ect.

Forge and vanilla BlockState generator.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.