Jump to content

[1.15.2] Why DeferredWorkQueue don‘t work and cause me crashs?


Recommended Posts

Hello, i have posted a topic in them i ask why my OreGen function (

) don‘t worked and @diesieben say me that i actually need to use DeferredWorkQueue. I tried but i am getting this error log: https://github.com/DragonGamerDevelopers/Minecraft-Modding-Logs/blob/master/LOG.log

The Main error was: „Registry Object not present“. Now i am confused: Why it say me that the Registry Object (My Ore) was not present if before it perfectly worked? I am registering my ore with the new registering method: The DeferredRegister. I have think that the DeferredWorkQueue run after the game has loaded but before the DeferredRegister can run: then it simply not find my block because the block don‘t was registered. My final question: How to resolve this and was here a alternative to the DeferredWorkQueue? My Main.java: https://github.com/DragonGamerDevelopers/NewFantasyMod/blob/1.15.2/src/main/java/mod/dragonita/fantasymod/Main.java

Edited by DragonITA

New in Modding? == Still learning!

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.