Jump to content

Connection Timing Out


Recommended Posts

I have a remote system that I RDP(Remote Desktop Protocol) to in order to host my server. The server is on a completely separate network with the business plan from my ISP. Previously the server was able to host modded server fine, but recently when I started hosting new modpacks on the server, I have been experiencing issues connecting to the server myself. All the other players on my server can connect without issues, however when I connect, I am able to play for a few seconds before I get timed out. The server logs also start spamming:


[Netty Server IO #3/ERROR] [FML]: NetworkDispatcher exception
java.io.IOException: An existing connection was forcibly closed by the remote host

    at sun.nio.ch.SocketDispatcher.writev0(Native Method) ~[?:1.8.0_241]
    at sun.nio.ch.SocketDispatcher.writev(Unknown Source) ~[?:1.8.0_241]
    at sun.nio.ch.IOUtil.write(Unknown Source) ~[?:1.8.0_241]
    at sun.nio.ch.SocketChannelImpl.write(Unknown Source) ~[?:1.8.0_241]
    at io.netty.channel.socket.nio.NioSocketChannel.doWrite(NioSocketChannel.java:432) ~[minecraft_server.1.12.2.jar:?]
    at io.netty.channel.AbstractChannel$AbstractUnsafe.flush0(AbstractChannel.java:856) [minecraft_server.1.12.2.jar:?]
    at io.netty.channel.nio.AbstractNioChannel$AbstractNioUnsafe.forceFlush(AbstractNioChannel.java:368) [minecraft_server.1.12.2.jar:?]
    at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:618) [minecraft_server.1.12.2.jar:?]
    at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:559) [minecraft_server.1.12.2.jar:?]
    at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:476) [minecraft_server.1.12.2.jar:?]
    at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:438) [minecraft_server.1.12.2.jar:?]
    at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:858) [minecraft_server.1.12.2.jar:?]
    at java.lang.Thread.run(Unknown Source) [?:1.8.0_241]

I have tried running older modpacks or vanilla and did not experience this issue. I also suspected this may have been a modpack issue, so I tried another mod which resulted in the same error.

Any help or suggestion is appreciated :)


Link to comment
Share on other sites

  • Guest locked this topic
This topic is now closed to further replies.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.