Jump to content

Custom recipes not showing up + Controlling recipe unlock [1.15.2]

Recommended Posts

Hey all,


So, I have added shapeless crafting recipes for a Mod Gem Block as well as recipes for a set of trusty Mod Gem tools. Problem is, none of the shaped crafting recipes are loading in Minecraft when I run it, only the shapeless one. I can't see the shaped recipes in the recipe book, nor can they be crafted. Any idea why this is?


My recipes are all .json files, located in src/main/resources/data.thorneislearningmods.recipes.


Link to comment
Share on other sites

Also, post logs. (for the reason below)

I created some json recipe files from the commandline using echo, and for some reason it put an invisible character in the very beginning of my file, even though everything looked right, they didn't work, and there were errors in the log. Creating a new file and then pasting the json in fixed it.

Of course, this can all be avoided by using data generators :) (which I haven't looked at yet lol)

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.