Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

[1.15.2] Trouble implementing simple capabilities (ICapabilitySerializable cannot be resolved to a type)


Delupara
 Share

Recommended Posts

The title says it all, The docs says "if the capability needs to store data persistently it is possible to implement ICapabilitySerializable<T extends NBTBase>". I tried yet ICapabilitySerializable is not valid. I think either my setup is broken or the docs are outdated.

 

Relevant classes:

MemeStorage.java

Spoiler

package com.delupara.dankmemes.capabilities;

import net.minecraft.nbt.CompoundNBT;
import net.minecraft.nbt.INBT;
import net.minecraft.util.Direction;
import net.minecraftforge.common.capabilities.Capability;
import net.minecraftforge.common.capabilities.Capability.IStorage;

public class MemeStorage implements IStorage<IMeme>{

	@Override
	public INBT writeNBT(Capability<IMeme> capability, IMeme instance, Direction side) {
		// TODO Auto-generated method stub
		CompoundNBT tag = new CompoundNBT();
		tag.putInt("Meme Points", instance.getMemePoints());
		return tag;
	}

	@Override
	public void readNBT(Capability<IMeme> capability, IMeme instance, Direction side, INBT nbt) {
		CompoundNBT tag = (CompoundNBT) nbt;
		instance.setMemePoints(tag.getInt("Meme Points"));
	}
	
}

 

Meme.java
 

Spoiler

package com.delupara.dankmemes;

import com.delupara.dankmemes.capabilities.IMemeLevel;

public class Meme extends DankItem implements IMemeLevel {

	private int points;
	
	private int NextLevel;
	
	private int Level;
	
	
	public Meme(Properties properties, String name) {
		super(properties, name);
		}


	@Override
	public int getMemePoints() {
		// TODO Auto-generated method stub
		return points;
	}


	@Override
	public void setMemePoints(int amount) {
		// TODO Auto-generated method stub
		points = amount;
	}


	@Override
	public int getNextLevel(int PreviousLevelCap) {
		return PreviousLevelCap*2;
	}

	@Override
	public void LevelUp() {
		Level += 1;
		NextLevel = getNextLevel(NextLevel);
	}

}

 

 IMeme.java
 

Spoiler

package com.delupara.dankmemes.capabilities;

public interface IMeme 
{
	int getMemePoints();
	void setMemePoints(int amount);
	
}

 

 


MemeProvider.java (Where I'm trying to extend ICapabilitySerializable<CompoundNBT>) has no lines except a blank constructor. The error is in the title. Please help.

Edited by Delupara
Mistake

When they say your code doesn't follow convention but ur edgy so u dont care

d-d-d-dab on them haterz

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Hello There! In the 73rd episode of Bed Wars we get into a lobby with a guy who had a cool name and for some reason Ben is very impressed with the name and thus the title!  
    • I have been trying to install forge, but I can't even get the installer to run. I'm really not sure what the issue is, first let me make sure I am even using the installer right, I downloaded the forge installer matching my minecraft version (1.19.2), if I double click the .jar from the download then I see a flash of a black window that immediately disappears. If I use a command prompt, I receive the following output: C:\Users\austi> java -jar forge-1.19.2-43.0.19-installer.jar Error: Unable to access jarfile forge-1.19.2-43.0.19-installer.jar   I feel like this is more likely a java issue than a forge issue but I was hoping that people here might be able to help. I've tried a couple versions of java, at first I was using 8 I believe because all of the install guides for forge were a bit older so they linked to the java website rather than oracle. I tried version 18 from the oracle site and received the same result from command prompt. It is also entirely possible that I am doing something else wrong that is blatantly obvious to everyone else.
    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.