Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Resolve func_### problem


ArcaneDiver
 Share

Recommended Posts

15 minutes ago, ArcaneDiver said:

I can't find some function because their name is func_### than i see that i could resolve this issue by refreshing mappings but can't figure out how do that.

 

 

Edit your build.gradle

find this line:

Quote

mappings channel: 'snapshot', version: '20200422-1.15.1'

I usually change the version to whatever yesterday was.

 

Then refresh your project, and it should redo everything for ya.

  • Thanks 1
Link to comment
Share on other sites

41 minutes ago, Ugdhar said:

mappings channel: 'snapshot', version: '20200422-1.15.1'

I put this. It works, but in some method the name of parameters are p_176208_1_, is it solvable?

 

 

In my config there was this: 

   mappings channel: 'snapshot', version: '20190719-1.14.3'

 

But i did't understand how choose the version

Edited by ArcaneDiver
Link to comment
Share on other sites

20 minutes ago, ArcaneDiver said:

some method the name of parameters are p_176208_1_, is it solvable?

Not everything has been mapped yet, so you either have to wait until someone does, or figure out and submit it yourself to MCPBot (or something like that, I haven't really done any messing with that stuff yet, I just use what they gimme :) )

 

21 minutes ago, ArcaneDiver said:

But i did't understand how choose the version

http://export.mcpbot.bspk.rs/ has the latest/stable mappings. I just use the (close to) latest one, has more stuff mapped, and someone said somewhere that the snapshot ones don't get broken very often so it's relatively safe to do.

If you're not using 1.15.2, I'm not sure if using the 1.15.1 mappings is bad or not for 1.14.x (or if it even works). I just do everything in the latest version myself.

  • Thanks 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • Here is my configuration: % java -version java version "18.0.2" 2022-07-19 Java(TM) SE Runtime Environment (build 18.0.2+9-61) Java HotSpot(TM) 64-Bit Server VM (build 18.0.2+9-61, mixed mode, sharing) forge-1.19-41.1.0-mdk on macOS Monterey 12.5 I ran the command: ./gradlew genEclipseRuns and was hoping it will generate the Eclipse project files for me. The run log is at https://gist.github.com/arun-gupta/06b983a6976b4c0a0f510d0dc225ddd3 and the generated directory structure is at https://gist.github.com/arun-gupta/3f5bfc70ec5d3d903b0f97d42840abda. In previous versions (1.12-ish), it used to generate an eclipse directory but 1.19 does not seem to have it. I tried opening the top-level forge directory but Eclipse does not recognize it as a project as well. How do I open this project in Eclipse now?  
    • I didn't put in credentials, I used it only for testing installing forge. But still the problem mentioned above.
    • I am trying to use Forge 1.18.2, I have checked my firewall, redownloaded Forge, deleted the fml.toml file (which keeps reappearing) and looked at countless help pages. I am just trying to download and use forge so that I can play with my friends and it will not download. It tells me there may be an issue with the Java runtime config and that the exit code is one, and I have copied the exit code.   
    • Okay, i think i understand but im getting issues, i create another packet to sync entity to another players like this package com.naim.belloto.networking.packet; import com.naim.belloto.networking.handler.ClientSyncHandler; import net.minecraft.client.Minecraft; import net.minecraft.network.FriendlyByteBuf; import net.minecraftforge.api.distmarker.Dist; import net.minecraftforge.fml.DistExecutor; import net.minecraftforge.network.NetworkEvent; import java.util.Objects; import java.util.function.Supplier; public class ClientSyncPacket { public ClientSyncPacket() { } public ClientSyncPacket(FriendlyByteBuf buf) { } public void toBytes(FriendlyByteBuf buf) { } public boolean handle(Supplier<NetworkEvent.Context> ctx) { NetworkEvent.Context context = ctx.get(); context.enqueueWork(() -> { assert Minecraft.getInstance().player != null; int idplayer = Minecraft.getInstance().player.getId(); DistExecutor.unsafeCallWhenOn(Dist.CLIENT,() -> () -> ClientSyncHandler.handlePacket(ctx, idplayer)); }); return true; } } And in the handler: public class ClientSyncHandler { public static boolean handlePacket(Supplier<NetworkEvent.Context> ctx, int idPlayer) { Minecraft.getInstance().level.getEntity(idPlayer); return true; } } But is not working :// 
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.