Jump to content

Mods not loading on Mac OS but working fine on windows

Recommended Posts

I host my own server for me and my friends to play on. It has been working great for a while now but another friend wanted to join but he is on Mac os. I helped him download the forge client on his computer and gave him all the mods that we use, but it never gets out of the loading screen. We are on 1.15.2 and using 59 mods (see below), when JEI is installed the loading screen gets stuck on Atlas stitching for JEI. But when I removed JEI and associated mods from the mod pack it gets stuck on MOD SETUP: Sided setup. I've tried upping the allocated ram but it still doesn't finish loading

Any ideas would be great.




-Block of Charcoal

-Advanced finders

-Large Ore deposits

-"To the Bat Poles!"

-AI Improvements

-Ambient Sounds 3

-Apple Skins

-Attribute Fix

-Better Than Llamas


-Bad wither no cookie




-Config 2

-Crafting stations


-Double Slabs

-Elevator (openblocks)

-Equipment tool tips

-Fast furnace and Fast workbench

-Fast Leaf decay

-Forge Endertech





-Jei integration

-Journey Map

-Just enough resources


-Klee Slabs

-Light overlay


-Mining helmet


-Modpack config checker


-Mouse Tweaks

-Natures Compass


-Nether Portal Fix

-No recipe book

-Ore Excavation




-Random Patches

-Server Tab Info


-Swing though grass

-Torch Master

-U team core

-Useful Backpacks



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • So, I try to make a katana, with katana and scabbard, is that possible to make 2 different models to be on player while he holding item? Katana in hands, and scabbard at belt. 
    • I created a server with the Pixelmon mod, it's fine and everything but a person enters and the server closes, I don't know how to explain it very well but I attach the detailed file of the error that happens to me https://mclo.gs/eSemvtq This error had not happened to me until now, so I don't understand very well why this happens, could you help me solve it?
    • When I create the server and log in it lets me play, but a person ends up joining and it sends me an error and the server closes The report says Exception in server tick Loop I put here what the console tells me because I honestly don't know how to explain it: https://mclo.gs/eSemvtq I use Forge mods and this has not happened to me until now 
    • Sorry I wasn't on this site for a few days. But anyways, if you just simply want to install forge to play with mods, you need to click on the installer option, thqat way, forge will be automatically installed to your device at the version you chose. Then you could just open Minecraft launcher to play on that version.
    • I've been putting together a modpack for a few weeks, and it's worked just fine. Until today, I logged onto my survival world and went exploring. As soon as I entered my boat the game froze and crashed. Now when I try to start the world, nothing loads and the game crashes. I tried creating a new world and the same thing happened when I tried to use a boat. Here's the latest crash report from the original world: If anyone knows how to fix the issue, I'd really appreciate the help, thanks.
  • Topics

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.