Jump to content

[1.12.2] Gradle dependencies fetching problem


Elsopeen

Recommended Posts

Hello, I'm new to modding and gradle and I just got the hand of an old mod getting ported to 1.12.2. It was on an old version of forge and ForgeGradle so I updated that, but I still have a problem with the dependencies.

So basically the previous modder used the JEI API, but when Gradle tries to fetch the file from the maven repo, the mapping properties get added to the name like that :

deobf "mezz.jei:jei_${mc_version}:${jei_version}:api"
  
Could not find mezz.jei:jei_1.12.2:4.15.0.291_mapped_stable_39-1.12

I attached the build.gradle in which the dependencies are defined and the gradle.properties in which are defined the "mc_version" and "jei_version".

I have litterally no idea why this occurs, but I hope your wisdom will help me.

 

Just for info,

IntelliJ IDEA 2020.1.2 (Ultimate Edition)
Build #IU-201.7846.76, built on June 1, 2020
Runtime version: 11.0.7+10-b765.53 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 980M
Cores: 4
Non-Bundled Plugins: com.demonwav.minecraft-dev, org.jetbrains.kotlin

 

I use JDK 8u251 (latest from Oracle), Forge 1.12.2-14.23.5.2854 (latest too), with ForgeGradle 3+ and Gradle 4.10.3.

I don't think the stacktrace is really useful here as the only error is this online fetching one.

Thanks by advance :)

build.gradle gradle.properties

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.

Announcements



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.