• Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hello,   I have problems updating my flower generation to 1.16.3. As already mentioned in the topic, I want to make my custom flower generate in some vanilla biomes. Here is my code:  public static void setupFlowerGeneration() { for(Biome biome: ForgeRegistries.BIOMES) { if(biome==ForgeRegistries.BIOMES.getValue(new ResourceLocation("savanna"))){ BiomeGenerationSettings.Builder GENERATION_SETTINGS = (new BiomeGenerationSettings.Builder()).func_242519_a(biome.func_242440_e().func_242500_d()); GENERATION_SETTINGS.func_242513_a(GenerationStage.Decoration.VEGETAL_DECORATION, BiomeFeatures.HEART_FLOWER); } } } My BiomeFeatures.HEART_FLOWER looks like this: public static final ConfiguredFeature<?, ?> HEART_FLOWER = register("heart_flower", Feature.RANDOM_PATCH.withConfiguration((new BlockClusterFeatureConfig.Builder((new WeightedBlockStateProvider()).addWeightedBlockstate(BlockList.heart_flower.getDefaultState(), 2), new SimpleBlockPlacer())).tries(64).build()).withPlacement(Placement.TOP_SOLID_HEIGHTMAP.configure(new NoPlacementConfig()))); private static <FC extends IFeatureConfig> ConfiguredFeature<FC, ?> register(String key, ConfiguredFeature<FC, ?> feature) { return Registry.register(WorldGenRegistries.field_243653_e, new ResourceLocation(DeepAffection.modid, key), feature); } I also already tested: The setupFlowerGeneration() method gets called and also the if gets called, but somehow my flowers don't generate. By the way - I can see on github of other people that their methods have clear names while mine always only have those func_1231411513 names. Does anyone know why I have this?   I hope someone can help me - Thank you in advance.  
    • So I'm trying to load Minecraft up on my Laptop using Forge 1.16.1 and for some reason it just won't load fully. It stops at either the REGISTERING stage, or when it gets to the Atlas stitching stage with the Shulker Box texture. The version I have is in Beta, and I'm not sure if the version up now is the same or not. Please help!
    • So i really wanted to play jurassicraft again but the mod devs decided that they would slash the amount of creatures HEAVILY for the rest of the updates so the only "good" one for me is pre release 5 HOWEVER there seems to be some kind of issue with LLibrary or FORGE because no matter what i do when i try to launch the game i get this error. I have tried asking for help from the jurassicraft discord but they just blew me off with a "no support questions about pre release" so this is literally MY LAST hope   The game crashed whilst there was a severe problem during mod loading that has caused the game to fail Error: net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: Could not initialize class org.jurassicraft.JurassiCraft Exit Code: -1 also here is the full crash log   ---- Minecraft Crash Report ---- WARNING: coremods are present:   llibrary (llibrary-1.5.1-1.8.9.jar) Contact their authors BEFORE contacting forge // Surprise! Haha. Well, this is awkward. Time: 9/26/20 6:07 PM Description: There was a severe problem during mod loading that has caused the game to fail net.minecraftforge.fml.common.LoaderException: java.lang.NoClassDefFoundError: Could not initialize class org.jurassicraft.JurassiCraft     at net.minecraftforge.fml.common.LoadController.transition(LoadController.java:162)     at net.minecraftforge.fml.common.Loader.loadMods(Loader.java:543)     at net.minecraftforge.fml.client.FMLClientHandler.beginMinecraftLoading(FMLClientHandler.java:208)     at net.minecraft.client.Minecraft.func_71384_a(Minecraft.java:417)     at net.minecraft.client.Minecraft.func_99999_d(Minecraft.java:329)     at net.minecraft.client.main.Main.main(SourceFile:124)     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)     at java.lang.reflect.Method.invoke(Method.java:497)     at net.minecraft.launchwrapper.Launch.launch(Launch.java:135)     at net.minecraft.launchwrapper.Launch.main(Launch.java:28) Caused by: java.lang.NoClassDefFoundError: Could not initialize class org.jurassicraft.JurassiCraft     at java.lang.Class.forName0(Native Method)     at java.lang.Class.forName(Class.java:348)     at net.minecraftforge.fml.common.ProxyInjector.inject(ProxyInjector.java:43)     at net.minecraftforge.fml.common.FMLModContainer.constructMod(FMLModContainer.java:540)     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)     at java.lang.reflect.Method.invoke(Method.java:497)     at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)     at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)     at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)     at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)     at com.google.common.eventbus.EventBus.post(EventBus.java:275)     at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:211)     at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:189)     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)     at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)     at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)     at java.lang.reflect.Method.invoke(Method.java:497)     at com.google.common.eventbus.EventSubscriber.handleEvent(EventSubscriber.java:74)     at com.google.common.eventbus.SynchronizedEventSubscriber.handleEvent(SynchronizedEventSubscriber.java:47)     at com.google.common.eventbus.EventBus.dispatch(EventBus.java:322)     at com.google.common.eventbus.EventBus.dispatchQueuedEvents(EventBus.java:304)     at com.google.common.eventbus.EventBus.post(EventBus.java:275)     at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:118)     at net.minecraftforge.fml.common.Loader.loadMods(Loader.java:512)     ... 10 more A detailed walkthrough of the error, its code path and all known details is as follows: --------------------------------------------------------------------------------------- -- System Details -- Details:     Minecraft Version: 1.8.9     Operating System: Windows 10 (amd64) version 10.0     Java Version: 1.8.0_51, Oracle Corporation     Java VM Version: Java HotSpot(TM) 64-Bit Server VM (mixed mode), Oracle Corporation     Memory: 197354392 bytes (188 MB) / 972554240 bytes (927 MB) up to 3008888832 bytes (2869 MB)     JVM Flags: 4 total; -XX:HeapDumpPath=MojangTricksIntelDriversForPerformance_javaw.exe_minecraft.exe.heapdump -Xmx3228m -Xms256m -XX:PermSize=256m     IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0     FML: MCP 9.19 Powered by Forge 11.15.1.2318 8 mods loaded, 8 mods active     States: 'U' = Unloaded 'L' = Loaded 'C' = Constructed 'H' = Pre-initialized 'I' = Initialized 'J' = Post-initialized 'A' = Available 'D' = Disabled 'E' = Errored     UC    mcp{9.19} [Minecraft Coder Pack] (minecraft.jar)      UC    FML{8.0.99.99} [Forge Mod Loader] (forge-1.8.9-11.15.1.2318-1.8.9.jar)      UC    Forge{11.15.1.2318} [Minecraft Forge] (forge-1.8.9-11.15.1.2318-1.8.9.jar)      UC    customnpcs{1.8.9} [CustomNPCs] (CustomNpcs_1.8.9(29oct16).jar)      UE    jcanimationapi{1.2.5} [JurassiCraft AnimationAPI] (JurassiCraft 2.0.0 Pre-release 5.jar)      UE    net/timeless/unilib{${unilib_version}} [Unilib] (JurassiCraft 2.0.0 Pre-release 5.jar)      UC    llibrary{1.5.1} [LLibrary] (llibrary-1.5.1-1.8.9.jar)      UE    jurassicraft{2.0.0-pre} [JurassiCraft] (JurassiCraft 2.0.0 Pre-release 5.jar)      Loaded coremods (and transformers):  llibrary (llibrary-1.5.1-1.8.9.jar)   net.ilexiconn.llibrary.server.core.plugin.LLibraryTransformer   net.ilexiconn.llibrary.server.core.patcher.LLibraryRuntimePatcher     GL info: ' Vendor: 'NVIDIA Corporation' Version: '4.6.0 NVIDIA 452.06' Renderer: 'GeForce GTX 1060 6GB/PCIe/SSE2'                        
    • The tick only happens with 20 FPS, you need to lerp in the renderer for the frames in between (3 for 60FPS)
  • Topics

  • Who's Online (See full list)