Jump to content

Again encoding bug with forge src


robin4002

Recommended Posts

Traceback (most recent call last):
  File "install.py", line 76, in <module>
    decompile=options.decompile, gen_conf=False)
  File "install.py", line 17, in fml_main
    disable_assets=disable_assets)
  File "C:\Users\RÚbecca\Desktop\modding\forge-1.6.1-757\fml\fml.py", line 1013,
in decompile_minecraft
    pre_decompile(mcp_dir, fml_dir, disable_assets=disable_assets)
  File "C:\Users\RÚbecca\Desktop\modding\forge-1.6.1-757\fml\fml.py", line 1061,
in pre_decompile
    download_minecraft(mcp_dir, fml_dir)
  File "C:\Users\RÚbecca\Desktop\modding\forge-1.6.1-757\fml\fml.py", line 1125,
in download_minecraft
    failed = download_libraries(mcp_dir, version_json['libraries'], mc_info['nat
ives_dir']) or failed
  File "C:\Users\RÚbecca\Desktop\modding\forge-1.6.1-757\fml\fml.py", line 1180,
in download_libraries
    file_path = os.path.join(lib_dir, os.sep.join(path), file_name)
  File "ntpath.pyc", line 108, in join
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe9 in position 10: ordinal
not in range(128)

 

I have try to move forge folder in C:/, it's work.

It's again an encoding bug

 

(I'm going to kill my sister who had the idea to put his name in the session name)

Link to comment
Share on other sites

Ugh, it's 3Am and I honestly can't remember what I did last time to fix it. So if you would be so kind to provide me a link to the old issue i'll take a look at it in the morning.

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

The first time the bug had appeared in 1.4.5 :

https://github.com/MinecraftForge/MinecraftForge/issues/272

 

However, I can't find  which build has fix the bug, I'm still doing tests

 

EDIT : #395 to #443 = encoding bug

#444 work fine

the bug has been fixed by the build 444, I think it is this commit : https://github.com/MinecraftForge/MinecraftForge/commit/ff30c11bb5382ca5d95039c4bb914ff0ad2f0b01

Link to comment
Share on other sites

Humm thanks for that, I could of sworn I actualyl fixed it before. But that changeset isn't telling me anything.

And I cant seem to fix it.. I'll work on it, but no promises for now.

 

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Consider supporting the team on Patreon

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.