Jump to content

Can't run Forge 1.6.1 from within eclipse


culegooner
 Share

Recommended Posts

Hello!

 

I'm trying to run forge from within eclipse and everytime I'm getting this error

 

Exception in thread "main" java.lang.NullPointerException

at java.util.logging.Logger.setParent(Logger.java:1472)

at net.minecraft.logging.LogAgent.setupLogger(LogAgent.java:33)

at net.minecraft.logging.LogAgent.<init>(LogAgent.java:25)

at net.minecraft.client.Minecraft.<init>(Minecraft.java:306)

at net.minecraft.client.main.Main.main(Main.java:77)

at Start.main(Start.java:68)

 

I don't use the eclipse workspace given in MCP instead I have my own with the following setup:

 

my eclipse enviroment in the Java Build Path

Source folder pointing at minecraft

jars folder is linked to the project but not set as source

Libraries and all of the jars from the jars/libraries folder are all added to the project and selected in the Order and Export tab

jars/version/1.6.1/1.6.1.jar is also added and selected

Native library location set for lwjgl* and jinput pointing at forge161/jars/versions/1.6.1/1.6.1-natives

 

My run configuration is

Main class: Start

Working Directory: ${workspace_loc:forge161/jars}

No arguments

 

All of source is compiled correctly in eclipse with 0 errors but with a lot of warnings.

 

I tried this exact same setup for running decompiled minecraft 1.6.1 with MCP but without forge and it runs fine.

 

I also used to use this setup to run forge for 1.5.2 with no problems

 

I tried running it from forge/mcp/startclient.bat and that is not working either, it's giving the same error:

 

 

 

== MCP 8.01 (data: 8.02, client: 1.6.1, server: 1.6.1) ==

[01:56:30] Exception in thread "main" java.lang.NullPointerException

[01:56:30]      at java.util.logging.Logger.setParent(Logger.java:1472)

[01:56:30]      at net.minecraft.logging.LogAgent.setupLogger(LogAgent.java:33)

[01:56:30]      at net.minecraft.logging.LogAgent.<init>(LogAgent.java:25)

[01:56:30]      at net.minecraft.client.Minecraft.<init>(Minecraft.java:306)

[01:56:30]      at net.minecraft.client.main.Main.main(Main.java:77)

[01:56:30]      at Start.main(Start.java:68)

'"C:\Program Files\Java\jdk1.7.0_21\bin\java" -Xincgc -Xms1024M -Xmx1024M -cp ".

.\bin\minecraft;..\sr...' failed : 1

FATAL ERROR

Traceback (most recent call last):

  File "runtime\startclient.py", line 30, in startclient

  File "C:\minecraft\forge161\folder\forge\mcp\runtime\commands.py", line 1355,

in startclient

    self.runmc(forkcmd)

  File "C:\minecraft\forge161\folder\forge\mcp\runtime\commands.py", line 1395,

in runmc

    raise CalledProcessError(process.returncode, forkcmd, output)

CalledProcessError: Command '"C:\Program Files\Java\jdk1.7.0_21\bin\java" -Xincg

c -Xms1024M -Xmx1024M -cp "..\bin\minecraft;..\src\minecraft;..\jars\versions\1.

6.1\1.6.1.jar;..\lib;..\lib\*;..\jars\libraries\net\java\jinput\jinput\2.0.5\jin

put-2.0.5.jar;..\jars\libraries\org\lwjgl\lwjgl\lwjgl-platform\2.9.0\lwjgl-platf

orm-2.9.0-natives-windows.jar;..\jars\libraries\org\apache\commons\commons-lang3

\3.1\commons-lang3-3.1.jar;..\jars\libraries\com\paulscode\libraryjavasound\2010

1123\libraryjavasound-20101123.jar;..\jars\libraries\net\sf\jopt-simple\jopt-sim

ple\4.5\jopt-simple-4.5.jar;..\jars\libraries\com\google\guava\guava\14.0\guava-

14.0.jar;..\jars\libraries\lzma\lzma\0.0.1\lzma-0.0.1.jar;..\jars\libraries\org\

ow2\asm\asm-all\4.1\asm-all-4.1.jar;..\jars\libraries\com\paulscode\codecjorbis\

20101023\codecjorbis-20101023.jar;..\jars\libraries\org\bouncycastle\bcprov-jdk1

5on\1.47\bcprov-jdk15on-1.47.jar;..\jars\libraries\com\paulscode\soundsystem\201

20107\soundsystem-20120107.jar;..\jars\libraries\com\paulscode\librarylwjglopena

l\20100824\librarylwjglopenal-20100824.jar;..\jars\libraries\org\scala-lang\scal

a-library\2.10.2\scala-library-2.10.2.jar;..\jars\libraries\org\lwjgl\lwjgl\lwjg

l_util\2.9.0\lwjgl_util-2.9.0.jar;..\jars\libraries\org\scala-lang\scala-compile

r\2.10.2\scala-compiler-2.10.2.jar;..\jars\libraries\net\java\jutils\jutils\1.0.

0\jutils-1.0.0.jar;..\jars\libraries\org\lwjgl\lwjgl\lwjgl\2.9.0\lwjgl-2.9.0.jar

;..\jars\libraries\commons-io\commons-io\2.4\commons-io-2.4.jar;..\jars\librarie

s\net\sourceforge\argo\argo\2.25\argo-2.25.jar;..\jars\libraries\com\google\code

\gson\gson\2.2.2\gson-2.2.2.jar;..\jars\libraries\com\paulscode\codecwav\2010102

3\codecwav-20101023.jar;..\jars\libraries\net\java\jinput\jinput-platform\2.0.5\

jinput-platform-2.0.5-natives-windows.jar;..\jars\libraries\net\minecraft\launch

wrapper\1.3\launchwrapper-1.3.jar" -Djava.library.path=..\jars\versions\1.6.1\1.

6.1-natives Start' returned non-zero exit status 1

Press any key to continue . . .

 

 

 

 

I can't run the Minecraft forge server either:

For the server I added the jars/minecraft_server.1.6.1.jar to the Library and selected for export

The run configuration for the server is:

Main class: net.minecraft.server.MinecraftServer

 

The error is:

Exception in thread "main" java.lang.ExceptionInInitializerError

at net.minecraft.block.Block.<clinit>(Block.java:1409)

at net.minecraft.stats.StatList.initMinableStats(StatList.java:185)

at net.minecraft.stats.StatList.<clinit>(StatList.java:96)

at net.minecraft.server.MinecraftServer.main(MinecraftServer.java:1387)

Caused by: java.lang.ClassCastException: sun.misc.Launcher$AppClassLoader cannot be cast to net.minecraft.launchwrapper.LaunchClassLoader

at cpw.mods.fml.common.ModClassLoader.<init>(ModClassLoader.java:45)

at cpw.mods.fml.common.Loader.<init>(Loader.java:183)

at cpw.mods.fml.common.Loader.instance(Loader.java:163)

at cpw.mods.fml.common.registry.GameData.newItemAdded(GameData.java:101)

at net.minecraft.item.Item.<init>(Item.java:272)

at net.minecraft.item.ItemTool.<init>(ItemTool.java:28)

at net.minecraft.item.ItemSpade.<init>(ItemSpade.java:12)

at net.minecraft.item.Item.<clinit>(Item.java:48)

... 4 more

 

the mcp/startserver.bat is also giving an error, but it has more to do for not adding the launchwrapper-1.3.jar to the classpath

 

any ideas?

 

 

 

 

 

Link to comment
Share on other sites

Turns out this is an FML issue.

 

configureLogging in FMLRelaunchLog is never called so the Logger isn't properly initialized before it's called in Minecraft.java :(

 

I just have no idea how everybody else seems to be running forge and modding, it's virtually impossible at the moment since the cpw package is missing some functionality. but what the hell do I know.

 

I'll wait :)

 

Link to comment
Share on other sites

Actually its not a FML issue.

Its a launch configuration issue. We ship those for a reason u.u

You need to launch the legacylauncher.Launch class

Not Start.main

https://github.com/MinecraftForge/FML/blob/master/install/eclipse/.metadata/.plugins/org.eclipse.debug.core/.launches/Client.launch

I do Forge for free, however the servers to run it arn't free, so anything is appreciated.
Patreon: http://www.patreon.com/lexmanos
Paypal: http://paypal.me/LexManos

BitCoin: 1Q8rWvUNMM2T1ZfDaFeeYQyVXtYoeT6tTn

Link to comment
Share on other sites

Thank YOU!!! SO MUCH!

I really felt i was out of the loop!

 

I did try the net.minecraft.launchwrapper.Launch at some point but that gave me an error, didn't know the arguments. so i dismissed it.

Thank you for pointing me to that file, I would have never guessed.

 

Main Class:

net.minecraft.launchwrapper.Launch

 

Program arguments:

--version 1.6 --tweakClass cpw.mods.fml.common.launcher.FMLTweaker

 

 

But trying to run the Server still gives the error I mentioned above

I checked the Server.launch and it's the same as mine, no arguments and calling net.minecraft.server.MinecraftServer. any ideas on that one?

https://github.com/MinecraftForge/FML/blob/master/install/eclipse/.metadata/.plugins/org.eclipse.debug.core/.launches/Server.launch

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • I figured out what was wrong ... you can spot it pretty quick most likely: { "type": "minecraft:smelting", "ingredient": { "item": "minecraft:gold_nugget_ore" }, "result": "minecraft:gold_nugget", "experience": 0.25, "cookingtime": 150 }   ... so, after changing `minecraft` to `foundations` for all the custom items and all the recipes work. Well that's what copy/paste will get you. One last question about recipes, though. What does the following json key/value do in the game? "group": "copper_ingot"  
    • # Copyright (c) 1993-2009 Microsoft Corp. # # This is a sample HOSTS file used by Microsoft TCP/IP for Windows. # # This file contains the mappings of IP addresses to host names. Each # entry should be kept on an individual line. The IP address should # be placed in the first column followed by the corresponding host name. # The IP address and the host name should be separated by at least one # space. # # Additionally, comments (such as these) may be inserted on individual # lines or following the machine name denoted by a '#' symbol. # # For example: # #      102.54.94.97     rhino.acme.com          # source server #       38.25.63.10     x.acme.com              # x client host # localhost name resolution is handled within DNS itself. #    127.0.0.1       localhost #    ::1             localhost ###0.0.0.0 apps.corel.com ###0.0.0.0 mc.corel.com 0.0.0.0 origin-mc.corel.com ###0.0.0.0 iws.corel.com
    • Is there a way to create a custom map marker for a custom structure/biome (same as a vanilla mansion)?
    • I’ve scrounged the Internet for solutions and found absolutely nothing that has worked for me I have posted my code in a GitHub Repository. I bet the culprit is somewhere in the Container or TileEntity classes (Furnace packages are in blocks/coke_furnace or blocks/foundry) PS I know I’m on 1.12.2 and that it’s not supported I don’t want to update my game or my code. Lol It’s my favorite version and the most widely modded. I don’t plan to release the mod, I’m just customizing my game to my will. I’ll send it to friends but that’s it.
    • 1.19.2 With forge 43.2.4   https://mclo.gs/zCAx1MG      
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.