Jump to content

1.16.4 Server installation library download failure


Recommended Posts

I've been using forge server on my pc for the past month or so with no issues, but due to me messing with mod files earlier this week the server wouldn't work anymore. I decided it would be best to just delete it and make a clean install, however I keep running into issues with this where I previously didn't so I'm wondering if I might be doing something wrong.

First the forge download page would not let me download the installer client. I don't have a screenshot since this issue seems to have resolved itself after about an hour of trying (maybe its still useful information though idk), but the error message was something like "AppData\Local\Temp\k900E+YJ.jar.part could not be saved, because the source file could not be read.". I googled the error and it seems to indicate a connection issue. Like I said this seems to now have been resolved and I was able to re-download the installer, but now I get the following when trying to run it:

These are the files it does create, running the .jar file does not create any other folders like normally.

I tried doing this multiple times, each time deleting the files that were created or making a new folder for it. After this didn't work google led me to this forum post from a few year back that had some suggestions but different library errors: 

After reading through the post and some articles I found I tried the following:
- Updated java and when that didn't work reinstalled it.
- Made sure I'm using a .jar file
- Opened a command prompt in the folder where I had the .jar file and tried java -Djava.net.preferIPv4Stack=true -jar [name of the installer] where I replaced the [name of the installer] with the file name. This returned "Error: Could not find or load main class .net.preferIPv4Stack=true".

- Opened a command prompt in the folder where I had the .jar file and tried -Xnx2G -jar forge.jar (from this video: https://www.youtube.com/watch?v=jXVNaSI6mwY). This returned "-Xnx2G : The term '-Xnx2G' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again."
- Disabled my antivirus and firewall

- Tried it on a different device on the same network (wireless but only a few meters or around 12 feet away from the router)
- Updated Windows to latest version

As a side note, the forge forums and website are all taking a noticeably longer time to load than any other website. I did two speed tests with an hour in between and it seems decent enough to me, not that I'm very tech savvy though (ping 6 then 5, down 43 then 26, up 40 then 38).

I'll attach the log file here: https://pastebin.com/3pK7yeQr
I'm using the 1.16.4 - 35.1.35 version of the installer for both the client and server.

Additionally I just found this recent post that has a similar issue but again, different errors: https://forums.minecraftforge.net/topic/97227-1164-server-install-these-libraries-failed-to-download/?tab=comments#comment-441882

Would really appreciate any suggestions!

Link to comment
Share on other sites

I've been having the same issues with the same Minecraft version. I have trouble installing some libraries through the installer. The fact that many people are creating similar threads along with the observations you made makes me think there's something wrong with their servers. Let's wait a bit and see.

Also just a tip: your syntax for the java commands seems to be off. The correct command is:

java -Xmx2G -jar forge.jar

You seem to have put an "n" instead of an "m".


Also, I don't know why, but my former reply was deleted without any notice. Really strange indeed

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use.