Jump to content

[SOLVED] FML doesn't recognize my mod


Prepared
 Share

Recommended Posts

Hey guys,

first off i'm really new to modding Minecraft so i'm a complete noob and the first thing i was doing was for testing purposes, just to see if it was working at all.

So i made a simple testing block with a new texture and a recipe. I was reading tutorials about all that stuff just to make sure that everything was done completely right.

 

Now to my problem, when i put my .zip mod file into the mods folder that is created by the newest forge mod loader version, the forge mod loader simply doesn't recognize my mod, it  completely ignores it, it doesn't even show an error message.

Client> 2013-07-05 20:37:25 [iNFO] [ForgeModLoader] Forge Mod Loader has identified 3 mods to load
Client> 2013-07-05 20:37:25 [iNFO] [mcp] Activating mod mcp
Client> 2013-07-05 20:37:25 [iNFO] [FML] Activating mod FML
Client> 2013-07-05 20:37:25 [iNFO] [Forge] Activating mod Forge

So apparently as you can see it loads the standart forge mod loader parts, but not my own mod. I looked through the entire development console output but it doesn't even mention my mod.

 

The thing is, that my mod works completely fine when i start minecraft in eclipse and when i put other 1.6.1 mods into the mods folder FML recognizes them. Of course i recompiled, reobfuscated and ziped the stuff i coded just like it was mentioned in the tutorials.

Since i can't figure out what i'm doing wrong i thought i might get some help from you guys.

 

It would be great if you could help me, and please don't be too hard on me, as i said i am completely new to these things.

Thanks in advance!

Link to comment
Share on other sites

Ok, since it seemed like no one was able to help me, i got back to it and played a little bit around with the folders. First i came to the conclusion that for some reason i have to but the unziped folder into the mods folder, I don't know why but that is uncommon, isn't it?

So now the block was in the game but it had the purple/black (missing texture) texture. The good thing was that the development console now helped me and told me in which folder it couldn't find the texture.

When i programmed the code in eclipse i put the texture in src/minecraft/assets/%modname%/textures/blocks/.

Now i knew it wouldn't work if i created an assets folder in the mods folder, so i came to the conclusion that i had to put the .png into /mods/%modname%/assets/%modname%/textures/blocks/.

 

I know this seems somehow wrong but it works and i'm glad it does. I don't know why it doesn't work when i use the same directory structure in a .zip file but i guess i have to be happy with what i got.

If someone knows how to solve the .zip issue, please let me know, i'd appreciate it.

Link to comment
Share on other sites

do you have a mcmod.info file?

 

[
{
  "modid": "",
  "name": "",
  "description": "",
  "version": "",
  "mcversion": "",
  "url": "",
  "updateUrl": "",
  "authors": [ "" ],
  "credits": "",
  "logoFile": "",
  "screenshots": [],
  "parent":"",
  "dependencies": []
}
]

 

Is the zip structure correct?

<yourzip>/mcmod.info

<yourzip>/assets/%modname%/textures/

<yourzip>/%modpackage%/<mod files>    <= I figure this is correct as it works unziped

Link to comment
Share on other sites

do you have a mcmod.info file?

 

Is that necessary to make the .zip work?

 

<yourzip>/assets/%modname%/textures/

<yourzip>/%modpackage%/<mod files>    <= I figure this is correct as it works unziped

 

I tried that out but it didn't work.

Link to comment
Share on other sites

  • 5 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.