Jump to content

Hook Error


Recommended Posts

Um hey there I am having an error with minecraf tforge that is apperently causing a hook eroor by what I could guess from the crash log and here it is

[spoiler/]Mods loaded: 9

ModLoader 1.2.5

mod_ModLoaderMp 1.2.5v1


mod_digimon Digimon 0.6.2

mod_pokemobs .5

mod_TooManyItems 1.2.5 2012-04-13

mod_Timber 1.2.4

mod_EllianDetector V1.30 [1.2.5]

mod_gempack TFC's Gem Pack (RECODED) Including: Topaz, Amethyst, Ruby, Sapphire, Apatite, Obsidian, Opal, and Emerald Tools/Armor


      Minecraft has crashed!     



Minecraft has stopped running because it encountered a problem.





--- BEGIN ERROR REPORT 436b8421 --------

Generated 5/6/12 2:28 PM


Minecraft: Minecraft 1.2.5

OS: Windows 7 (amd64) version 6.1

Java: 1.7.0_02, Oracle Corporation

VM: Java HotSpot 64-Bit Server VM (mixed mode), Oracle Corporation

LWJGL: 2.4.2

OpenGL: ATI Radeon HD 4200  version 3.3.10834 Compatibility Profile Context, ATI Technologies Inc.


java.lang.NoSuchMethodError: yw.getCurrentPlayerStrVsBlock(Lpb;I)F

at forge.ForgeHooks.blockStrength(ForgeHooks.java:489)

at pb.blockStrength(Block.java:1217)

at pb.blockStrength(Block.java:1205)

at aes.a(PlayerControllerSP.java:85)

at net.minecraft.client.Minecraft.c(Minecraft.java:1346)

at net.minecraft.client.Minecraft.k(Minecraft.java:1789)

at net.minecraft.client.Minecraft.x(Minecraft.java:819)

at net.minecraft.client.Minecraft.run(Minecraft.java:747)

at java.lang.Thread.run(Unknown Source)

--- END ERROR REPORT a139b4c1 ----------


I have tried and experimented and have found that the problem seems to be that is the object you are using to left click a block with is able to break it, minecraft would crash and for ex. i mean if you use any diamond tool to try to break a block it will crash but if you left click a diamond block with wood tool it will not break but if you hit a dirt block with with your hand you will crash as well etc.


YOu are still able to right click and activate and place blocks though with no problem . Also the way they are listed in the crash report is how I installed the mods in that exact order oddly enough lol As far as I know none of the mods change a base class file so help is greatly appreciated because I would love to have these mods working in a series I want to do.

Link to comment
Share on other sites

not to my knowledge no but I have tried removing mod by mod and it seems that everything works fine up until i use forge and then the mods that required it the gems and the detector being those mods. however if i had to guess it would be the gem's mod as it adds alot of itmes here a link if it helps



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Unfortunately, your content contains terms that we do not allow. Please edit your content to remove the highlighted words below.
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.