Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Crashing on Startup after Initialization 1.15.2


Recommended Posts

Hi, 

After 1 day of playing without issues, my game keeps crashing on start up with a rendering overlay error.

I play with a friend on a private server that we set up, so we have identical mods, resource packs and shaders (literally sent him a zip of my files). For some reason, I have experienced this crash when he hasn't experienced a single one. I have better specs and allocate more ram to the game without being the one hosting the server and needing to allocate resources to it.

Here is a long winded explanation of things that I have tried, but the TLDR is that I basically ran out of posts to read through and decided to post.

Spoiler

I checked that the version of Optifine was compatible with Forge.
I made sure to download the mods for the 15.2 version of Minecraft from Curse Forge.
I changed the render distance to 8.
I made sure the launcher closed on startup.
I allocated more and less RAM to the game (2,4,8,12GB).
I removed some mods I believed to be problematic, like Immersive Engineering.
I tried multiple resource packs. BDCraft and Chromahills. 128px and 512px.
I tried multiple shaderpacks. KUDA Shaders and BSL.
I tried deleting config files (This allowed it to sometimes start up, once, which eventually ended in the same crash), did not seem to be a reliable or sustainable solution.
Tried different version of Forge (31.2.45 and 31.2.50) with fresh installs of Minecraft and Forge each time. 
I did not try removing and adding individual mods because, as I said, myself and my friend are running identical files and he hasn't had an error since we started.
I installed the latest version of Java and graphics drivers.
I use a gaming laptop, have heard that there might be issues with onboard/discreet gpus (vanilla runs without issue though).
Noticed a lot of similar errors in posts using 2060/2070 cards, not sure if this is related at all.

Crashes seem to occur most often after changing shader/resource packs or whenever I enter the game after getting it to randomly run once after deleting the configs.
Sometimes it would run without shaders/resource packs, but not reliably.

Logs:
 

Crash Report

Latest

Debug

I hope this post provides enough detail, if anything is missing, please let me know. 
I am out of ideas and know very little to actually make any real use of the logs.
Any help would be appreciated.


EDIT: forgot to add the error message.

The game crashed whilst rendering overlay Error: java.lang.NullPointerException: Rendering overlay Exit Code: -1

Edited by PeerPope
Link to post
Share on other sites
  • PeerPope changed the title to Crashing on Startup after Initialization 1.15.2

Ah thanks. Well, I did the mods one by one thing today. Got it working with most  of them then realised I had Biomes of Plenty and BYG in the same pack. Removed BYG. Got it running. For the entire afternoon, with full resources and shaders. 

Then it randomly started doing the same. Took out Botania like you suggested. Got it working again. Not sure how stable it is yet (might be a test over a few days sorta thing).

I'm still confused how my mate with the exact same file setup hasn't had a single issue yet though. What is in my system that causes it to trigger for me and not for him?

I appreciate the suggestions though. This has been destroying my will to live for 4 days now.

Link to post
Share on other sites

Would it be useful for me to post a mod list? To see if I have any vestigial files or dependencies without coremods hanging around in there? Would that cause issues?

Link to post
Share on other sites

I mostly saw this issue with modpacks that were missing dependencies. The problem is, the crash is not Botania's fault. It might still crash with other mods. A modlist might be usefull.

Edited by Thorius
grammar
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



  • Recently Browsing

    No registered users viewing this page.

  • Posts

    • Hi, I am new to modding and am having a little trouble when it comes to rgistering a custom recipe serializer to generate my recipe. It's a simple single item recipe so I tired to extend the singleItemRecipeBuilder, however I keep getting the following error when I runData. [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]: Caused by: java.lang.ExceptionInInitializerError [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at com.kup.burgercraft.util.recipe.MeatGrindingRecipeBuilder.meatGrinding(MeatGrindingRecipeBuilder.java:16) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at com.kup.burgercraft.data.ModRecipeProvider.RegisterMeatGrinding(ModRecipeProvider.java:52) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at com.kup.burgercraft.data.ModRecipeProvider.buildShapelessRecipes(ModRecipeProvider.java:20) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at net.minecraft.data.RecipeProvider.run(RecipeProvider.java:50) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at net.minecraft.data.DataGenerator.run(DataGenerator.java:44) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at net.minecraftforge.fml.event.lifecycle.GatherDataEvent$DataGeneratorConfig.lambda$runAll$0(GatherDataEvent.java:111) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at cpw.mods.modlauncher.api.LamdbaExceptionUtils.lambda$rethrowConsumer$0(LamdbaExceptionUtils.java:34) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at java.base/java.util.HashMap$Values.forEach(HashMap.java:976) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at net.minecraftforge.fml.event.lifecycle.GatherDataEvent$DataGeneratorConfig.runAll(GatherDataEvent.java:107) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at net.minecraftforge.fml.DatagenModLoader.begin(DatagenModLoader.java:61) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     at net.minecraft.data.Main.main(Main.java:43) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:648]:     ... 11 more [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:671]: Caused by: java.lang.IllegalStateException: Cannot register new entries to DeferredRegister after RegistryEvent.Register has been fired. [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:671]:     at net.minecraftforge.registries.DeferredRegister.register(DeferredRegister.java:111) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:671]:     at com.kup.burgercraft.setup.ModRecipes$Serializers.<clinit>(ModRecipes.java:26) [01:46:59] [main/INFO] [STDERR/]: [java.lang.Throwable:printStackTrace:671]:     ... 22 more below is a few pastebins of hopefully the more relavant clases ModRecipeProvider MeatGrindingRecipe ModRecipes Registration   Many thanks for any assiance you might be able to lend.  
    • Hello There! The finale is FINALLY here of this really wholesome video series! In this one we switch some things up and we surprise my one friend with a MINECRAFT ACCOUNT! Then we get back to the usual stuff where we surprise the ones who have Java Minecraft with their statues and everything! Sadly this little series was cut short because of the server shutting down but it was fun nonetheless! If you are looking for a wholesome/good vibe video series this is the one for you! I hope you all enjoy this video and if you did don't forget to like and sub for more!  
    • My forge 1.12.2 shows up in launcher and the tap shows up when I launches at the bottom of my screen. The game itself doesn't pop up on my screen. When launching forge again, it will just say that a game is already there. Can someone please help me solve this problem? I have already tried searching for multiple instances of minecraft using task manager, finding nothing. 
    • After looking through a ton of functions, I found the issue was that my entity was extending MonsterEntity, which extends MobEntity, which creates a GroundPathNavigator, which has a rules for canUpdatePath that include "this.mob.isOnGround()". My entity is a flying entity. Whoops. Solution was to simply override the createNavigation function, where I simply "return new FlyingPathNavigator(this, world);". Everything works fine now.
    • do you already have a custom recipe implemented? if not, you'll a class that'l hold the recipe and check for matches, the recipe inventory and the recipe serializer   then it's up to you to write the logic in your container. you can use of the world's recipe manager to see if a recipe inventory matches any recipe
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.