Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

ForgeGradle

Help and support for the new ForgeGradle system of building mods.


1055 topics in this forum

    • 1 reply
    • 698 views
    • 2 replies
    • 247 views
    • 1 reply
    • 347 views
  1. weird maven error

    • 2 replies
    • 516 views
    • 1 reply
    • 265 views
    • 6 replies
    • 502 views
    • 1 reply
    • 328 views
    • 1 reply
    • 290 views
    • 6 replies
    • 464 views
    • 7 replies
    • 271 views
    • 12 replies
    • 441 views
    • 3 replies
    • 673 views
    • 10 replies
    • 566 views
    • 1 reply
    • 370 views
    • 1 reply
    • 337 views
    • 1 reply
    • 315 views
    • 1 reply
    • 274 views
    • 2 replies
    • 275 views
    • 9 replies
    • 330 views
    • 7 replies
    • 391 views
    • 4 replies
    • 842 views
    • 5 replies
    • 370 views
    • 9 replies
    • 3.9k views
  2. Missing library?

    • 4 replies
    • 470 views
    • 0 replies
    • 229 views


  • Posts

    • Hi can any help me to fix this bug? (the structure cut of when i spawn it)
    • Sorry, I also just started with learning coding. But the documentation don't solve the problem! (The Problem is what I underline here: "new DeferredRegister<>(ForgeRegistries.ITEMS, TestMod ..." public static final DeferredRegister<Item> ITEMS = new DeferredRegister<>(ForgeRegistries.ITEMS, TestMod.MOD_ID); Hole Code: package com.NotHeizer.TestMod.util; import com.NotHeizer.TestMod.TestMod; import com.NotHeizer.TestMod.items.ItemBase; import net.minecraft.item.Item; import net.minecraftforge.fml.RegistryObject; import net.minecraftforge.fml.javafmlmod.FMLJavaModLoadingContext; import net.minecraftforge.registries.DeferredRegister; import net.minecraftforge.registries.ForgeRegistries; public class RegisteryHandler { public static final DeferredRegister<Item> ITEMS = new DeferredRegister<>(ForgeRegistries.ITEMS, TestMod.MOD_ID); public static void init() { ITEMS.register(FMLJavaModLoadingContext.get().getModEventBus()); //Items public static final RegistryObject<Item> RUBY = ITEMS.register("ruby", ItemBase::new) } This was my "util" package. If I go into my TestMod (the Name of my Mod) Package there is 1 related Problem: package com.NotHeizer.TestMod; import com.NotHeizer.TestMod.util.RegisteryHandler; import net.minecraftforge.common.MinecraftForge; import net.minecraftforge.fml.common.Mod; import net.minecraftforge.fml.event.lifecycle.FMLClientSetupEvent; import net.minecraftforge.fml.event.lifecycle.FMLCommonSetupEvent; import net.minecraftforge.fml.javafmlmod.FMLJavaModLoadingContext; import org.apache.logging.log4j.LogManager; import org.apache.logging.log4j.Logger; @Mod("TMod") public class TestMod { private static final Logger LOGGER = LogManager.getLogger(); public static final String MOD_ID = "TestMod"; public TestMod() { FMLJavaModLoadingContext.get().getModEventBus().addListener(this::setup); FMLJavaModLoadingContext.get().getModEventBus().addListener(this::doClientStuff); RegisteryHandler.init(); MinecraftForge.EVENT_BUS.register(this); } private void setup(final FMLCommonSetupEvent event) { } private void doClientStuff(final FMLClientSetupEvent event) { } } You can't see it, but after: @Mod("TMod") public class TestMod { private static final Logger LOGGER = LogManager.getLogger(); and Befor: public static final String MOD_ID = "TestMod"; there stands: "1 related Problem" in red and if I klick on it, it sends me to: "new DeferredRegister<>(ForgeRegistries.ITEMS, TestMod ..." (btw"DeferredRegister<>" is than marked. I am a beginner, and I am not good at it, but I read through the documentation and could not find something that could help me, or I am still not good enough. Can you help me?   Sorry for my bad englisch And I saw your Name, it sounds German, so if you are German, I am too so pleas write me in German if you can so that I could understand easily! Tanks in advanced!  
    • Should I call the read and write methods of my NBTHandler in any event?
    • Here is debug.log: [19Apr2021 20:46:59.810] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher running: args [--gameDir, ., --launchTarget, fmlserver, --fml.forgeVersion, 36.1.0, --fml.mcpVersion, 20210115.111550, --fml.mcVersion, 1.16.5, --fml.forgeGroup, net.minecraftforge] [19Apr2021 20:46:59.816] [main/INFO] [cpw.mods.modlauncher.Launcher/MODLAUNCHER]: ModLauncher 8.0.9+86+master.3cf110c starting: java version 16 by Oracle Corporation [19Apr2021 20:46:59.832] [main/DEBUG] [cpw.mods.modlauncher.LaunchServiceHandler/MODLAUNCHER]: Found launch services [minecraft,testharness,fmlclient,fmlserver]  
    • I can confirm I am experiencing issues as well. It seems like all https://files.minecraftforge.net/maven/... URLs are being redirected to https://maven.minecraftforge.net/... which throws an authentication prompt and doesn't seem to work.
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.