Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Support & Bug Reports

Help with Forge goes here. Refer to Modder Support for help with Forge modding. You MUST read the EAQ before posting.


25131 topics in this forum

    • 7 replies
    • 4.8m views
    • 1 reply
    • 55 views
    • 1 reply
    • 88 views
    • 1 reply
    • 146 views
    • 4 replies
    • 255 views
    • 1 reply
    • 149 views
    • 1 reply
    • 90 views
  1. (Help!!!)

    • 1 reply
    • 75 views
    • 1 reply
    • 174 views
    • 3 replies
    • 226 views
    • 21 replies
    • 890 views
    • 1 reply
    • 63 views
    • 1 reply
    • 76 views
    • 0 replies
    • 71 views
    • 8 replies
    • 320 views
    • 15 replies
    • 8.5k views
    • 2 replies
    • 96 views
    • 1 reply
    • 77 views
    • 5 replies
    • 233 views
    • 3 replies
    • 94 views
    • 2 replies
    • 210 views
  2. Programming problem

    • 2 replies
    • 155 views
    • 4 replies
    • 428 views
    • 8 replies
    • 252 views
    • 1 reply
    • 147 views


  • Posts

    • Is this the client or the server not starting? Show the debug.log.
    • Hello, I am trying to play Minecraft with a friend on a server but I need forge for it and it isn't starting. It just says this mesage: Memory Heap: 64 / 2048 MB (3,1%)   OffHeap: 36 MB It also doesn't tell me any bug reports. Please tell me how to fix it.
    • Don't be silly. A script kiddie is capable of basic copy pasting. I can't even do that. However, one more thing to add. How do you connect the registered FlowingFluidBlock, to your actual FluidBlock.class? I wasn't aware that you can actually customize the FlowingFluidBlock RegistryObject(or any other RegistryObject in that regard). Do it like that, and take info from the vanilla FluidBlocks how to build your FluidBlock.class accordingly: Change that...         public static final RegistryObject<FlowingFluidBlock> OIL_BLOCK = MatLibRegister.BLOCKS.register("crudeoil",             () -> new FlowingFluidBlock(() -> MatLibFluidOil.OIL_FLUID.get(), AbstractBlock.Properties.create(MATOIL)                     .doesNotBlockMovement().hardnessAndResistance(100f).noDrops()));           ...to that...         public static final RegistryObject<MyCustomFluidBlock> OIL_BLOCK = MatLibRegister.BLOCKS.register("crudeoil",             () -> new MyCustomFluidBlock(() -> MatLibFluidOil.OIL_FLUID.get(), AbstractBlock.Properties.create(MATOIL)                     .doesNotBlockMovement().hardnessAndResistance(100f).noDrops()));   ...and name your FluidBlock MyCustomFluidBlock.class. As far as I understand you do not want to extend to FlowableFluidBlock, but to FlowableFluid. I've yet to understand why, because in the past a fluid block, was still a block. It seems like it is now an "in between" thingy, or no longer a block at all. I hope someone of the wizards can spread some wisdom on that? And if it's just to ease the tinkering...👍 Edit: If someone wants more learning material, I'd recommend the TechReborn FlowableFluid.class, and their actual Fluid.class(Fabric only, so lots of adaptions needed, but good for getting an idea of structure), or PneumaticCraft(Forge). Notice they seem to be on 1.16.5 or even 1.17.1, but the code is compiling fine and dandy with minor adaptions(for 1.17.1 only?). You'd quickly find traces on how to "adapt" by highlighting methods/fields/etc., and open the declaration. Trouble starts really if references aren't public, because then you have to @Override in a custom.class. Which is something I've yet to learn as well. In the past, for 1.7(yes, that's 2013), it looked something like that:
    • just the error: https://pastebin.com/8duvMgPg debug.log: https://gist.github.com/RVOtakuMike/4e84ac2b090408a9dd8defeddbc96c24 latest.log: https://gist.github.com/RVOtakuMike/44f1dc0e7a52696c530136d51a619dfd World does load in single player when i transferred it over, though it said there were errors in the datapacks?? Then made me click "Safe mode". I wonder what i did wrong... any help is appreciated. Ive run minecraft (forge) servers for years and never had issues with save/load. (Though I am new to 1.16)
  • Topics

  • Who's Online (See full list)

×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.