Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

imawindow

Members
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral

About imawindow

  • Rank
    Tree Puncher
  1. alright. I meant as being registered and you can see its presence... lol i don't know how else to explain. So I'm just gonna register it and hide it from the creative tab if the mod is not downloaded and vice versa if it is.
  2. Like I want the items/blocks to be registered only when that mod is installed. else, remove the registry (almost like when you remove a mod, the content gets removed along side with it (obviously)). But like you said, I shouldn't do this. What is a good alternative?
  3. So i made a block type called "quarter stairs" and I would like to make it compatible with, let's say, Biomes O' Plenty blocks (ex:White Sandstone Quarter Stairs). I only want that to "appear" if Biomes O' Plenty is downloaded.
  4. ok. so what is a good way to approach this? or is this just not a good idea? lol. I want the block/item to appear if you have a mod installed.
  5. public static final DeferredRegister<Item> ITEMS = DeferredRegister.create(ForgeRegistries.ITEMS, Main.MOD_ID); public static final RegistryObject<Item> TEST_BLOCK_ITEM = itemRegistry("test_block_item", ModBlocks.TEST_BLOCK); private static RegistryObject<Item> itemRegistry(String registryName, RegistryObject<Block> block){ String user = System.getProperty("user.home"); File modFile = new File(user + "\\AppData\\Roaming\\.minecraft\\mods\\Test.txt"); boolean modExists = modFile.exists(); if(modExists) { return ITEMS.register(registryName, () -&
  6. Yo i'm good now. It was because of 1.16.1. Idk what happened but when i updated to 1.16.3, it never crashed again. (I provoked the crash by turning on a resource pack and flick the lever (idk why it crashes the game in 1.16.1 but it did)). Thx anyways
  7. Is there a possible chance that my mod might've affected this?
  8. I don't know how to explain this but I'll do my best. This happened three times to me now and I don't know whether it's my mod or minecraft that's doing this. (Context: I'm trying to setup for a youtube video on my mod). The first time this happened, I placed a block down (my block) and then the game froze and crashed. I logged back in to find out a chunk got deleted out of the world... i don't think thats the right word because it didn't really affect the y axis; it deleted like maybe a 16x16x20 area. I wish I had a screenshot but I deleted the old one and loaded a backup. The second time aro
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.