Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

gluszak

Members
  • Posts

    14
  • Joined

  • Last visited

Converted

  • Gender
    Undisclosed
  • Personal Text
    I am new!

gluszak's Achievements

Tree Puncher

Tree Puncher (2/8)

0

Reputation

  1. I'd like to be able to change the fog color when swimming in a custom liquid. Lava and water are done this way: int i = ActiveRenderInfo.getBlockIdAtEntityViewpoint(this.mc.theWorld, entityliving, par1); if (this.cloudFog) { Vec3 vec33 = worldclient.getCloudColour(par1); this.fogColorRed = (float)vec33.xCoord; this.fogColorGreen = (float)vec33.yCoord; this.fogColorBlue = (float)vec33.zCoord; } else if (i != 0 && Block.blocksList[i].blockMaterial == Material.water) { this.fogColorRed = 0.02F; this.fogColorGreen = 0.02F; this.fogColorBlue = 0.2F; } else if (i != 0 && Block.blocksList[i].blockMaterial == Material.lava) { this.fogColorRed = 0.6F; this.fogColorGreen = 0.1F; this.fogColorBlue = 0.0F; }
  2. Yeah, but I want to do it like it's done with water because I've added a new liquid. int i = ActiveRenderInfo.getBlockIdAtEntityViewpoint(this.mc.theWorld, entityliving, par1); if (this.cloudFog) { Vec3 vec33 = worldclient.getCloudColour(par1); this.fogColorRed = (float)vec33.xCoord; this.fogColorGreen = (float)vec33.yCoord; this.fogColorBlue = (float)vec33.zCoord; } else if (i != 0 && Block.blocksList[i].blockMaterial == Material.water) { this.fogColorRed = 0.02F; this.fogColorGreen = 0.02F; this.fogColorBlue = 0.2F; } else if (i != 0 && Block.blocksList[i].blockMaterial == Material.lava) { this.fogColorRed = 0.6F; this.fogColorGreen = 0.1F; this.fogColorBlue = 0.0F; }
  3. Why are you using mcp 7.44? It is designed for minecraft 1.5.1 and your forge is for 1.5.2
  4. Hi. I'd like to change EntityRender's fog color. I know that it's done in updateFogColor method, but the method is private and I can't see any possibility to insert my code.
  5. Hi. I've started updating Peronix's fan mod to 1.4.5 and Forge (#445). I have problems with Entity class. A few crashlogs: https://dl.dropbox.com/u/79065269/crash-reports.rar Sourcecode: https://dl.dropbox.com/u/79065269/gluszak.rar
  6. gluszak

    Guava 13

    I didn't have an opportunity to use the Guava library and generally I'm a Java newbie, but i've seen that there's a new version (13) and Forge still uses version 12.
  7. Hey, you didn't understand me. I don't want to play the sound all the time but only twice: once when i click a block and again after some time. But it plays only when i click on the block and it should also play when "asd" shows up in the console.
  8. "asd" shows up but sound plays only once
  9. Change your code to: ModMagicItems_EventSounds: package magicItems.common; import net.minecraftforge.client.event.sound.SoundLoadEvent; import net.minecraftforge.event.ForgeSubscribe; public class MagicItems_EventSounds { @ForgeSubscribe public void onSound(SoundLoadEvent event) { try { event.manager.soundPoolSounds.addSound("/magicItems/mirrorsound.wav", "magicItems/spelssounds/sounds/folder/mirrorsound.wav"); // So you should have mirrorsound.wav in your "src/common/magicItems/spelssounds/sounds/folder" folder and after compiling you should put it into "magicItems.zip/common/spelssounds/sounds/folder" } catch (Exception e) { System.err.println("Failed to register one or more sounds."); } } } BaseMod File: @PreInit public void load(FMLInitializationEvent initEvent){ //Sounds MinecraftForge.EVENT_BUS.register(new MagicItems_EventSounds()); } ItemMirror: public ItemStack onItemRightClick(ItemStack item, World world, EntityPlayer player) { world.playSoundAtEntity(player, "magicItems.mirrorsound", 1.0F, 1.0F); }
  10. Well, it looks like Optifine indeed is causing that bugs and crashes. Is it a common issue or am I the only one having it?
  11. Hi! I have trouble with my modded minecraft. My MC loads normally, it starts well, but after a while it crashes. My crash-reports folder is empty, there are only hs_err_pid### logs. Also, i have rendering bugs: creatures with missing body parts, sometimes the textures are wrong (for example, cows textured with dirt, or Steve's body turning blue). My mods: Logs: https://dl.dropbox.com/u/79065269/ForgeModLoader-client-0.log https://dl.dropbox.com/u/79065269/ForgeModLoader-client-1.log A pack of hs_err_pid logs: https://dl.dropbox.com/u/79065269/hs_err_pid.rar Screenshots: https://dl.dropbox.com/u/79065269/2012-10-25_18.04.32.png https://dl.dropbox.com/u/79065269/2012-10-25_18.04.42.png Also, my GPU if it matters: ATI Mobility Radeon HD 5800 Series
×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.