Jump to content

[1.6] Textures missing - how did I fuck this one up? O.o


Mazetar
 Share

Recommended Posts

Hi again!

So a quick basic question, and I know there are several tutorials and threads about how it's supposed to be done but I can't find what I'm doing wrong..

 

From what I can see I'm doing it correctly, of course I'm not else it would have worked, but I just can't spot the error -_- Could someone who ain't blind like me point it out for me? :)

 

Models import fine, which is located in the "assets\mazlt\models" folder, so I can't for the life of me see why the textures won't work.

 

Screenshot from eclipse showing the explorer and block registration.

http://oi41.tinypic.com/awrvoi.jpg

 

Project name is MazLearnedThis.

ModID = "mazlt"

Block textures are located at:

"MazLearnedThis\resources\assets\mazlt\textures\blocks"

 

I register the blocks icon by to (modid+":filename") as you can see in the image above.

 

So any suggestions? :)

 

 

 

If you guys dont get it.. then well ya.. try harder...

Link to comment
Share on other sites

Don't know.

 

But I do know that Tinypic is shit now, I suggest migrating to http://postimage.org/

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

yeah if I remember the name next time I need it, instead of googling for one to use ;)

 

Tinypic is full of ads now and doesn't give you direct links to the images, and if you do get the direct link (ending in .png or whatever) it still doesn't work for anyone you link it to (they still get a page full of porn ads).

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

Hmm didn't notice, just grabbed the direct link and tested to check it only showed the image (which it does for me) and pasted it here. I'll try to remember to stay away from tinypic in the future, thank you :)

If you guys dont get it.. then well ya.. try harder...

Link to comment
Share on other sites

tested to check it only showed the image (which it does for me)

 

Yeah...I know...

 

http://i41.tinypic.com/2ljt5l3.png

 

^ direct link for layouts showing the direct URL for another image I uploaded previously, showing that it is not surrounded by ads.

Apparently I'm a complete and utter jerk and come to this forum just like to make fun of people, be confrontational, and make your personal life miserable.  If you think this is the case, JUST REPORT ME.  Otherwise you're just going to get reported when you reply to my posts and point it out, because odds are, I was trying to be nice.

 

Exception: If you do not understand Java, I WILL NOT HELP YOU and your thread will get locked.

 

DO NOT PM ME WITH PROBLEMS. No help will be given.

Link to comment
Share on other sites

I'm not sure if You have tried this, I'm not 100% sure, that it will work. I had a similar issue, and I've been really pissed off, because I was sure i do everything just like in the tutorial, so eventually I created the most basic tutorial example following it step by step, even with the names. It worked. I tried to find the difference between my mod and this simple generic tutorial, but I couldn't find any.

 

Then I messed up a little with the basic example to see how I can make it screwed again, and i turned out that UPPERCASE LETTERS WERE THE CASE. I renamed my mod folders to all lowercase, without spaces, changed modID to lowercase and it worked.

Png files themselves didn't have to be changed to lowercase, thanks God. Shitty bug if You ask me.

Link to comment
Share on other sites

+1 to what Senitial said, the same thing happened to me, change your mod folder to lower case, and update the stuff in your mod code. I can't find it now, but I remember seeing someone else posting code from minecraft(not forge stuff), that pretty much translates your paths to lowercase, regardless if thats really the case.

Link to comment
Share on other sites

I have everything in lowercase already, it's not a bug it's just one of the common things in the programmers world :) The common standard is for such things to be all lowercase.

 

Thanks for the suggestion, I re-checked all the strings to be sure :)

If you guys dont get it.. then well ya.. try harder...

Link to comment
Share on other sites

all your textures sould be in the mcp/src/minecraft/assets/modname/blocks(items, whatever)/

so you create assets folder inside the mcp/src/minecraft/

After reobfuscating the game, you copy the assets folder from src/minecraft inside your .zip file.

 

If you are not sure about the paths, check the Eclipse console. When game launches it tries to load all the icons. If the icon is missing it is going to display a message like this in the console:

 

Using missing texture, unable to load: somemod:textures/blocks/someblock.png

 

That way you can determine if you have your textures in the right place.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share



  • Recently Browsing

    • No registered users viewing this page.
  • Posts

    • REM Forge requires a configured set of both JVM and program arguments. REM Add custom JVM arguments to the user_jvm_args.txt REM Add custom program arguments {such as nogui} to this file in the next line before the %* or REM  pass them to this script directly "C:\Program Files\Java\jdk-17\bin\Java.exe" @user_jvm_args.txt @libraries/net/minecraftforge/forge/1.18.2-40.1.80/win_args.txt -Xmx8G -Xms8G %* pause     so I used it.
    • I created an SOUL_JAR Item that has been registered for each mob like - mod:soul_jar_minecraft_cow etc.. but it all has different registry names, i have a model file name soul_jar.json and i want to know how to bind each of those items to this class (When mod iterates through all of vanilla mobs and registering items for them).   I didn't found any info about it because all of info is outdated, and forge docs is complicated asf (i wish there would be more examples) i also used AI but it showing me only outdated info, but theres some code where i registering my item and trying to bind it to model ->   public static void register(IEventBus eventBus){ ITEMS.register(eventBus); Set<ResourceLocation> entityKeyList = ForgeRegistries.ENTITY_TYPES.getKeys(); for (ResourceLocation k : entityKeyList) { EntityType<?> entityType = ForgeRegistries.ENTITY_TYPES.getValue(k); if (!entityType.getCategory().equals(MobCategory.MISC)) { RegistryObject<Item> SOUL_JAR = ITEMS.register("soul_jar" + '_' + k.toString().replace(':', '_').replace('.', '_'), () -> new JarItem(new Item.Properties().rarity(Rarity.RARE).tab(ModTabs.MAGICAL_OBSESSION_JARS), entityType)); if (Thread.currentThread().getThreadGroup() == SidedThreadGroups.CLIENT) { ItemModelShaper itemModelShaper = Minecraft.getInstance().getItemRenderer().getItemModelShaper(); itemModelShaper.register(SOUL_JAR.get().asItem(), new ModelResourceLocation("item.soul_jar", "inventory")); } } } } I also have more questions like how to iterate through all other mods mobs also, or render mob inside of a jar in inventory, but i will try to figure it out.
    • I looked into OctoEconomyAPI and saw that it was a JAR api for fabric. This means you have a fabric mod in your mods folder. I downloaded your mod folder and wasted 2 solid hours creating a Python script to try to find the faulty mod, and eventually just gave up. I suggest you create two installations with half or the mods in each, find which one doesn't launch, cut that one in half, and repeat until you find the fabric mod. Investigué OctoEconomyAPI y vi que era una API JAR para fabric. Esto significa que tienes un mod de Fabric en tu carpeta de mods. Descargué su carpeta de mods y desperdicié 2 horas completas creando un script de Python para tratar de encontrar el mod defectuoso, y finalmente me di por vencido. Le sugiero que cree dos instalaciones con la mitad o las modificaciones en cada una, encuentre cuál no se inicia, córtela por la mitad y repita hasta que encuentre la modificación Fabric.   (The Python script I made is here): (El script de Python que hice está aquí):  
    • I've got it to work now. Instead of using the texture manager I used the Render System:   RenderSystem.setShaderTexture(0, new ResourceLocation("mcaquests", "textures/item/questbook.png"));  
  • Topics

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.