Jump to content
Search In
  • More options...
Find results that contain...
Find results in...

Gradle Build Error -- Unsupported class file major version 60


Recommended Posts

Hi There,

 

Forge is giving me an error when I run the gradlew genEclipseRuns command in the mod project root folder. 

ForgeGradle1.thumb.PNG.593694199d053a52966a02c7b33fc7a9.PNG

My current specs are:

  • JDK 16.0.1 (64-bit version)
  • Forge MDK 1.16.5
  • Eclipse
  • I do not have the JRE installed as my Eclipse didn't like the version of the JVM associated with it.

When I installed the JRE, Eclipse gave me an error upon startup saying "Incompatible JVM. Version 1.8.0_261 of the JVM is not suitable for this product. Version: 11 or greater is required" or something almost exactly along those lines.

I realize that not having the JRE installed might cause a bit of a facepalm among the seasoned Java developers here (in case it wasn't already readily apparent, I'm not a seasoned Java developer). I wasn't sure how essential it was to have the JRE if I already have the JDK installed.

 

Any ideas or recommendations would be greatly appreciated!

Link to post
Share on other sites

If you're developing for Java you shouldn't have a JRE installed, only a JDK. A JDK already includes a JRE and having both doesn't really make sense.

Forge does not currently support Java 16. It is recommended to use Java 8 for modding, as that is the version that is shipped with the Minecraft launcher.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



×
×
  • Create New...

Important Information

By using this site, you agree to our Privacy Policy.